2019.12.7PAT冬季考试第二题 - 7-2 Block Reversing (25分)

35 篇文章 0 订阅

Given a singly linked list L. Let us consider every K nodes as a block (if there are less than K nodes at the end of the list, the rest of the nodes are still considered as a block). Your job is to reverse all the blocks in L. For example, given L as 1→2→3→4→5→6→7→8 and K as 3, your output must be 7→8→4→5→6→1→2→3.

Input Specification:

Each input file contains one test case. For each case, the first line contains the address of the first node, a positive N (≤10​5​​) which is the total number of nodes, and a positive K (≤N) which is the size of a block. The address of a node is a 5-digit nonnegative integer, and NULL is represented by −1.

Then N lines follow, each describes a node in the format:

Address Data Next

where Address is the position of the node, Data is an integer, and Next is the position of the next node.

Output Specification:

For each case, output the resulting ordered linked list. Each node occupies a line, and is printed in the same format as in the input.

Sample Input:

00100 8 3
71120 7 88666
00000 4 99999
00100 1 12309
68237 6 71120
33218 3 00000
99999 5 68237
88666 8 -1
12309 2 33218

Sample Output:

71120 7 88666
88666 8 00000
00000 4 99999
99999 5 68237
68237 6 00100
00100 1 12309
12309 2 33218
33218 3 -1

作者: 陈越

单位: 浙江大学

时间限制: 400 ms

内存限制: 64 MB

代码长度限制: 16 KB

这是一道块链表反转的题,也是自己比较有思路的一道题。

1.自己的解法

数组block_begin[]和block_end[],记录每个块的起点和终点的位置,然后将起点和终点反转即可,链表内部不需要动。

// ConsoleApplication4.cpp : 定义控制台应用程序的入口点。
//


#include<cstdio>
#include<vector>
#include<iostream>
#include<queue>
#include<stack>
#include<cstring>
#include<string>
using namespace std;

const int maxn = 100010;
int block_begin[maxn];
int block_end[maxn];
struct Node{
	int data, next;
}node[maxn];
/*
00100 8 3
71120 7 88666
00000 4 99999
00100 1 12309
68237 6 71120
33218 3 00000
99999 5 68237
88666 8 -1
12309 2 33218
*/

int main(){
	int root_addr, n, k;
	cin>>root_addr>>n>>k;
	for(int i =0; i < n; i++){
		int addr, data, next;
		scanf("%d%d%d",&addr,&data,&next);
		node[addr].data = data;
		node[addr].next = next;
	}
	int block = 0; // block 1~n
	int final_num;
	if( n % k == 0){
		block = n / k;
		final_num = k;
	}
	else{
		block = n / k + 1;
		final_num = n % k;
	}
	int cur_ptr = root_addr;
	int cnt = 0;
	int block_idx = 1; // from 1 to n
	while(cur_ptr != -1){
		cnt++;
		if(cnt % k == 1) block_begin[block_idx] = cur_ptr;
		if(cnt % k == 0 || cnt == n) block_end[block_idx++] = cur_ptr;
		cur_ptr = node[cur_ptr].next;
	}
	root_addr = block_begin[block_idx - 1];

	for(int i = block_idx - 1; i >= 1; i--){
		if(i == 1)
		{node[block_end[i]].next = -1;}
		else
			node[block_end[i]].next = block_begin[i - 1];
	}
	
	cur_ptr = root_addr;
	while(cur_ptr != -1){
		if(node[cur_ptr].next != -1)
			printf("%05d %d %05d\n",cur_ptr, node[cur_ptr].data, node[cur_ptr].next);
		else
			printf("%05d %d %d\n",cur_ptr, node[cur_ptr].data, node[cur_ptr].next);
		cur_ptr = node[cur_ptr].next;
	}
	return 0;
}

 2大神的解法

使用sort的方法巧妙将链表反转:三阶排序:1.is0k 2.group 3.index

对于这道题来说,主要是group比较重要。

太巧妙了!在Node的结构里直接加入{group、index},初始化后进行排序!

#include <cstdio>
#include <algorithm>
#include <vector>
using namespace std;
struct Node {
	int data,address,next;
	int isOk;
	int group, index;
	Node (){
		isOk=0;
	}
}node[100010];
bool cmp(Node a, Node b){
	if (a.isOk!=b.isOk) return a.isOk>b.isOk;
	else if (a.group!=b.group) return a.group>b.group;
	else return a.index<b.index;
}
int main(){
	int n,k;
	int begin;
	scanf("%d %d %d",&begin, &n, &k);
	for (int i=0; i<n; i++){
		int address, data, next;
		scanf("%d %d %d",&address, &data, &next);
		node[address].data=data;
		node[address].address=address;
		node[address].next=next;
	}
	int p=begin;
	int cnt=0;
	//group a[group][index]
	while (p!=-1){
		node[p].group=cnt/k;
		node[p].index=cnt%k;
		cnt++;
		node[p].isOk=1;
		p=node[p].next;
	}
	sort(node, node+100010, cmp);
	for (int i=0; i<cnt; i++){
		if (i!=cnt-1){
			printf("%05d %d %05d\n",node[i].address, node[i].data, node[i+1].address);
		}else {
			printf("%05d %d -1\n",node[i].address, node[i].data);
		}
	}
	return 0;
}

 

3总结

链表题可以巧妙的使用sort的多级排序功能,出其不意!

目描述 给定一个常数 $K$ 以及一个单链表 $L$,请编写程序将 $L$ 中每 $K$ 个结点反转。例如:给定 $L$ 为 1→2→3→4→5→6,$K$ 为 3,则输出应该为 3→2→1→6→5→4;如果 $K$ 为 4,则输出应该为 4→3→2→1→5→6,即最后不到 $K$ 个元素不反转。 输入格式 每个输入包含一个测试用例。每个测试用例第 1 行给出第 1 个结点的地址、结点总个数正整数 $N (\le 10^5)$、以及正整数 $K (\le N)$,即要求反转的子链结点的个数。结点的地址是 5 位非负整数,NULL 地址用 −1 表示。 接下来有 $N$ 行,每行格式为: Address Data Next 其中 Address 是结点地址;Data 是该结点保存的整数数据;Next 是下一结点的地址。目保证给出的链表不为空。 输出格式 对每个测试用例,顺序输出反转后的链表,其上每个结点占一行,格式与输入相同。 输入样例 00100 6 4 00000 4 99999 00100 1 12309 68237 6 -1 33218 3 00000 99999 5 68237 23333 2 33218 输出样例 00000 4 33218 33218 3 12309 12309 1 99999 99999 5 68237 68237 6 23333 23333 2 -1 析 本需要将链表中每 $K$ 个结点反转,可以采用迭代的方法,每次找到 $K$ 个结点,将这 $K$ 个结点反转,然后将这 $K$ 个结点的前驱结点指向反转后的第一个结点,将反转后的 $K$ 个结点的最后一个结点指向下一个要反转的结点,然后继续进行下一轮反转。 需要注意的是,如果链表长度不足 $K$,则不进行反转。 代码实现
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值