hdu6047 Maximum Sequence(贪心)

Maximum Sequence

Time Limit: 4000/2000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 452    Accepted Submission(s): 242


Problem Description
Steph is extremely obsessed with “sequence problems” that are usually seen on magazines: Given the sequence 11, 23, 30, 35, what is the next number? Steph always finds them too easy for such a genius like himself until one day Klay comes up with a problem and ask him about it.

Given two integer sequences {ai} and {bi} with the same length n, you are to find the next n numbers of {ai}:  an+1a2n . Just like always, there are some restrictions on  an+1a2n : for each number  ai , you must choose a number  bk  from {bi}, and it must satisfy  ai ≤max{ aj -j│ bk ≤j<i}, and any  bk  can’t be chosen more than once. Apparently, there are a great many possibilities, so you are required to find max{ 2nn+1ai } modulo  109 +7 .

Now Steph finds it too hard to solve the problem, please help him.
 

Input
The input contains no more than 20 test cases.
For each test case, the first line consists of one integer n. The next line consists of n integers representing {ai}. And the third line consists of n integers representing {bi}.
1≤n≤250000, n≤a_i≤1500000, 1≤b_i≤n.
 

Output
For each test case, print the answer on one line: max{ 2nn+1ai } modulo  109 +7。
 

Sample Input
  
  
4 8 11 8 5 3 1 4 2
 

Sample Output
  
  
27
Hint
For the first sample: 1. Choose 2 from {bi}, then a_2…a_4 are available for a_5, and you can let a_5=a_2-2=9; 2. Choose 1 from {bi}, then a_1…a_5 are available for a_6, and you can let a_6=a_2-2=9;
 
题意是说,已知两个序列a[1]~a[n],b[1]~b[n],求满足 ai ≤max{ aj -j│ bk ≤j<i}(即a[i]是a[b[k]]~a[i-1]的最大值)的序列a[n+1]~a[2n],求出max{ 2nn+1ai }。
要构造出尽可能大的a[i],就需要a[j]-j尽可能大,因此要使i较小时的a[i]尽量大,因此贪心策略就是按从小到大的顺序选取b[k],使得较前面的a[i]尽可能大,程序中我们分别记录a[i]-i~a[n]-n的最大值max[i](i<=n),和a[n+1]-n+1~a[i]-i(i>n)的最大值max1,来快速的求出下一个a[i]。
代码如下:
#include <bits/stdc++.h>
using namespace std;
#define inf 0x3f3f3f3f
const int mod = 1000000007;
int a[500005],b[500005],ma[500005],c[500005];//c[]为题目中b[],b[]为a[i]-i
int main()
{
	std::ios::sync_with_stdio(false);
	int n,i;
	int ma1,ma0;
	long long ans;
	while(cin>>n)
	{
		for(i=1; i<=n; i++)
		{
			cin>>a[i];
			b[i]=a[i]-i;
		}
		ma0=-inf;
		for(i=n; i>0; i--)
		{
			if(ma0<b[i])
			{
				ma0=b[i];
			}
			ma[i]=ma0;
		}
		for(i=1; i<=n; i++)
		{
			cin>>c[i];
		}
		sort(&c[1],&c[n+1]);
		ma1=-inf;
		ans=0;
		for(i=1; i<=n; i++)
		{
			a[i+n]=max(ma[c[i]],ma1);
			b[i+n]=a[i+n]-(i+n);
			if(b[i+n]>ma1)
			{
				ma1=b[i+n];
			}
			ans+=a[i+n];
			ans=ans%mod;
		}
		cout<<ans<<endl;
	}
	return 0;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值