HDU 2710 Max Factor

题目:

Description

To improve the organization of his farm, Farmer John labels each of his N (1 <= N <= 5,000) cows with a distinct serial number in the range 1..20,000. Unfortunately, he is unaware that the cows interpret some serial numbers as better than others. In particular, a cow whose serial number has the highest prime factor enjoys the highest social standing among all the other cows. 

(Recall that a prime number is just a number that has no divisors except for 1 and itself. The number 7 is prime while the number 6, being divisible by 2 and 3, is not). 

Given a set of N (1 <= N <= 5,000) serial numbers in the range 1..20,000, determine the one that has the largest prime factor. 

Input

* Line 1: A single integer, N 

* Lines 2..N+1: The serial numbers to be tested, one per line

Output

* Line 1: The integer with the largest prime factor. If there are more than one, output the one that appears earliest in the input file.

Sample Input

4
36
38
40
42

Sample Output

38
#include <iostream>
#include <stdio.h>
#include <algorithm>
#include <string.h>
#include <math.h>
#include <queue>
#include <vector>
#include <map>
using namespace std;
typedef long long LL;
typedef unsigned long long UL;
#define MS(x,y) memset(x,y,sizeof(x))
#define rpt(i,l,r) for(int i=l;i<=r;i++)
#define rpd(i,r,l) for(int i=r;i>=l;i--)
LL gcd(LL a,LL b){ return b==0?a:gcd(b,a%b);}
#define N 1000005
int prime[N];
void init(){
    int sum=0;
    prime[1]=sum;
    for(int i=2;i<N;i++){
        if(!prime[i]){
            sum++;
            prime[i]=sum;
            for(int j=i+i;j<N;j+=i){
                prime[j]=sum;
            }
        }
    }
}
int main()
{
    init();
    int n;
    while(scanf("%d",&n)!=EOF)
    {
        int temp;
        scanf("%d",&temp);
        int max=prime[temp];
        int mark=temp;
        n--;
        while(n--){
           scanf("%d",&temp);
           if(prime[temp]>max){
                max=prime[temp];
                mark=temp;
           }
        }
        printf("%d\n",mark);
    }
    return 0;
}

题意:农场主给牛编号了,哪头牛的最大素数因子在牛群中最大,那他的地位就最高,求出地位最高的牛。有n头牛 1<=n<=5000; 编号小于20000;

思路:用素数筛选法 :首先将20000以内的数都处理了,求出每个数的最大素数因子的处于素数的第几位。  每次输入的时候保留最大素数因子的数,最后输出那个数。

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值