HDU - 2710 - Max Factor【 筛法求素数 】题解

1.题目

To improve the organization of his farm, Farmer John labels each of his N (1 <= N <= 5,000) cows with a distinct serial number in the range 1…20,000. Unfortunately, he is unaware that the cows interpret some serial numbers as better than others. In particular, a cow whose serial number has the highest prime factor enjoys the highest social standing among all the other cows.

(Recall that a prime number is just a number that has no divisors except for 1 and itself. The number 7 is prime while the number 6, being divisible by 2 and 3, is not).

Given a set of N (1 <= N <= 5,000) serial numbers in the range 1…20,000, determine the one that has the largest prime factor.
Input

  • Line 1: A single integer, N

  • Lines 2…N+1: The serial numbers to be tested, one per line
    Output

  • Line 1: The integer with the largest prime factor. If there are more than one, output the one that appears earliest in the input file.
    Sample Input
    4
    36
    38
    40
    42
    Sample Output
    38

2.代码

#include<iostream>
#include<cstdio>
using namespace std;
const int maxn=20010;
int prime[maxn];
void isPrime()
{
	prime[1]=1;//特殊 筛法素数的改版 
	for(int i=2;i<maxn;i++)
	{
		if(prime[i]==0)
		{ 
		  prime[i]=i;
		  for(int j=i+i;j<maxn;j+=i)
		   prime[j]=i;//特殊 
		} 		
	}
}
int main()
{
   isPrime();
   int t,n,ans;
   while(cin>>t)
   {
   	 int max=0;
     for(int i=0;i<t;i++)
     {
   	   cin>>n;
   	   if(prime[n]>max)
   	   {
	      max=prime[n];
		  ans=n;	  
	   }
     }
     cout<<ans<<endl;
   }
   return 0;	
} 
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

林小鹿@

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值