hdu1312(附AC代码 )(DFS . BFS)

http://acm.hdu.edu.cn/showproblem.php?pid=1312

Red and Black

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 28886    Accepted Submission(s): 17481


 

Problem Description

There is a rectangular room, covered with square tiles. Each tile is colored either red or black. A man is standing on a black tile. From a tile, he can move to one of four adjacent tiles. But he can't move on red tiles, he can move only on black tiles.

Write a program to count the number of black tiles which he can reach by repeating the moves described above.

 

 

Input

The input consists of multiple data sets. A data set starts with a line containing two positive integers W and H; W and H are the numbers of tiles in the x- and y- directions, respectively. W and H are not more than 20.

There are H more lines in the data set, each of which includes W characters. Each character represents the color of a tile as follows.

'.' - a black tile
'#' - a red tile
'@' - a man on a black tile(appears exactly once in a data set)

 

 

Output

For each data set, your program should output a line which contains the number of tiles he can reach from the initial tile (including itself).

 

 

Sample Input

 

6 9 ....#. .....# ...... ...... ...... ...... ...... #@...# .#..#. 11 9 .#......... .#.#######. .#.#.....#. .#.#.###.#. .#.#..@#.#. .#.#####.#. .#.......#. .#########. ........... 11 6 ..#..#..#.. ..#..#..#.. ..#..#..### ..#..#..#@. ..#..#..#.. ..#..#..#.. 7 7 ..#.#.. ..#.#.. ###.### ...@... ###.### ..#.#.. ..#.#.. 0 0

 

 

Sample Output

 

45 59 6 13

 

简单的DFS  (深度优先搜索)

#include<iostream>
#include<cstdio>
#include<cstring>
using namespace std;

int n,m,ans; //一定不要 定义ans=1  全局变量!!!  输出会一直是1 (不要问我怎么知道)
char mp[25][25];
int vis[25][25];    // 最好用const int MAX  = 25
int s_x,s_y;
int dir[4][2]={0,-1,-1,0,0,1,1,0};
bool check(int x,int y){
    if(x<0 || x >= m || y < 0 || y >= n || vis[x][y] || mp[x][y] == '#')
    return false;
    return true;
    
}


void dfs(int x,int y)
{
    for(int i=0;i<4;++i)
    {
        int next_x = x + dir[i][0];
        int next_y = y + dir[i][1];
        if(check(next_x,next_y))
        {
            ans++;
            vis[next_x][next_y] = 1;
            dfs(next_x,next_y);
        }
    }
}

int main (){
    while(scanf("%d%d",&n,&m)!=EOF)//n代表列数  m代表行数
    {
        if(n ===0 && m==0)  break;
        memset(vis,0,sizeof(vis));
        ans=1;
        for(int i=0;i<m;++i)
        {
            for(int j=0;j<n;++j)
            {
                cin>>mp[i][j];   ///注意 如果是scanf会吃回车
                if(mp[i][j] == '@')
                {
                    s_x=i;
                    s_y=j;
                }
            }    
        }
        vis[s_x][s_y]=1;
        dfs(s_x,s_y);
        printf("%d\n",ans);
    }
    return 0;
}

 

BFS(广度优先搜索)

#include<cstdio>
#include<iostream>
#include<cstring> 
#include <queue>
using namespace std;

int n,m,ans; //一定不要 定义cou=1  全局变量 
char mp[25][25];
int vis[25][25];
int s_x,s_y;
int dir[4][2]={0,-1,-1,0,0,1,1,0};


struct node
{
    int x;
    int y;
    //int step;
//    node(int xx,int yy)
//    {
//        int x = xx;
//        int y = yy;
//        //int step = s;
//    }
};

bool check(int x,int y){
    if(x<0 || x >= m || y < 0 || y >= n || vis[x][y] || mp[x][y] == '#')
    return false;
    
    return true;
    
}

queue <node> q;
void bfs(int x, int y) {
    node now,n;
    now.x=x;
    now.y=y;
    q.push(now);
    while (!q.empty()) {
         now = q.front();
//        if (now.x == n - 1 && now.y == m - 1) {    //到达终点了 
//            cout << now.str << endl;
//            cout << now.step << endl;
//            break;
//        }
        q.pop();
        for (int i = 0; i < 4; i++) {
             n.x = now.x + dir[i][0];
             n.y = now.y + dir[i][1];
            if (check(n.x, n.y)) {
                ans++;
                q.push(n);
                vis[n.x][n.y] = 1;
            }
        }
    }
} 


int main (){
    while(scanf("%d%d",&n,&m)!=EOF)//n代表列数  m代表行数 
    {
        if(n ==0 && m==0)  break; 
        memset(vis,0,sizeof(vis));
        ans=1;
        for(int i=0;i<m;++i)
        {
            for(int j=0;j<n;++j)
            {
                cin>>mp[i][j];
                if(mp[i][j] == '@')
                {
                    s_x=i;
                    s_y=j;
                }
            }    
        }
        vis[s_x][s_y]=1;
        bfs(s_x,s_y);
        printf("%d\n",ans);
    }
    return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值