POJ - 2018 Best Cow Fences【前缀和】【二分】

【题目描述】
Farmer John’s farm consists of a long row of N (1 <= N <= 100,000)fields. Each field contains a certain number of cows, 1 <= ncows <= 2000.

FJ wants to build a fence around a contiguous group of these fields in order to maximize the average number of cows per field within that block. The block must contain at least F (1 <= F <= N) fields, where F given as input.

Calculate the fence placement that maximizes the average, given the constraint.

【输入】

  • Line 1: Two space-separated integers, N and F.

  • Lines 2…N+1: Each line contains a single integer, the number of cows in a field. Line 2 gives the number of cows in field 1,line 3 gives the number in field 2, and so on.

【输出】

  • Line 1: A single integer that is 1000 times the maximal average.Do not perform rounding, just print the integer that is 1000*ncows/nfields.

【样例输入】
10 6
6
4
2
10
3
8
5
9
4
1

【样例输出】
6500

题目链接:https://vjudge.net/problem/POJ-2018

POJ的测评机。。一言难尽啊。。。

代码如下:

#include <iostream>
#include <cstdio>
using namespace std;
#define EPS 1e-5
static const int MAXN=100000;
double a[MAXN+10],b[MAXN+10],s[MAXN+10];

int main()
{
    // std::ios::sync_with_stdio(false);
    // std::cin.tie(0),cout.tie(0);
    int n,f;
    cin>>n>>f;
    for(int i=1;i<=n;i++)
        //cin>>a[i];
        scanf("%lf",&a[i]);
    double l=-1e6,r=1e6;
    while(l+EPS<r)
    {
        double mid=(l+r)/2;
        for(int i=1;i<=n;i++)
            b[i]=a[i]-mid;
        for(int i=1;i<=n;i++)
            s[i]=s[i-1]+b[i];
        double ans=-1e10,min_val=1e10;
        for(int i=f;i<=n;i++)
        {
            min_val=min(min_val,s[i-f]);
            ans=max(ans,s[i]-min_val);
        }
        if(ans>=0)
            l=mid;
        else
            r=mid;
    }
    cout<<(int)(r*1000)<<endl;
    return 0;
}
  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值