Problem G: 类的继承

Problem G: 类的继承

Description :
设计一个实数类Rl和一个复数类Cx,其中Rl是Cx的父类,满足“Append Code”,完成程序。

Rl类由一个实部组成,Cx扩展了Rl类,增加了虚部,需要定义类的构造函数。类的功能有读取实部的函数re()、读取虚部的函数im(),输出由print()函数完成。

Input
输入为两个整数。
Output
见样例。
Sample Input
1 2
Sample Output
1
(1,2)

Append Code

int main()
{    
    int r, i;    
    cin >> r >> i;    
    Rl rl(r);    
    Cx cx(r, i);    
    rl.print();    
    cx.print();}

code:

#include <iostream>
using namespace std; 
class Rl{ 
public:    
    int a;
    Rl(int aa):a(aa){}    
    void print()    
    {        
    cout<<a<<endl;    
    }
}; 
class Cx:public Rl
{    
     int b;
public:    
     Cx(int aa,int bb):Rl(aa),b(bb){}    
     void print()    
     {        
          cout<<"("<<a<<","<<b<<")";    
     }
};
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值