The partial sum problem

描述
One day,Tom’s girlfriend give him an array A which contains N integers and asked him:Can you choose some integers from the N integers and the sum of them is equal to K. 
输入
There are multiple test cases.
Each test case contains three lines.The first line is an integer N(1≤N≤20),represents the array contains N integers. The second line contains N integers,the ith integer represents A[i](-10^8≤A[i]≤10^8).The third line contains an integer K(-10^8≤K≤10^8).
输出
If Tom can choose some integers from the array and their them is K,printf ”Of course,I can!”; other printf ”Sorry,I can’t!”.
样例输入
4
1 2 4 7
13
4
1 2 4 7
15
样例输出
Of course,I can!
Sorry,I can't!

代码:

#include<stdio.h>
#include<string.h>
using namespace std;
int arr[25];
int flag;
int n,m;
int Dfs(int step,int sum){
    if(step==n) return sum==m;
    if(Dfs(step+1,sum)) return 1; //加第step个数字 
    if(Dfs(step+1,sum+arr[step])) return 1;//不加第step个数字 
    return 0;
}
int main(){
	while(scanf("%d",&n)!=EOF){
		int i;
		for(i=0;i<n;i++)
		scanf("%d",&arr[i]);
		scanf("%d",&m);
		flag=Dfs(0,0);
		if(!flag) printf("Sorry,I can't!\n");
		else printf("Of course,I can!\n");
	}
	return 0;
}






partial_sum是C++ STL算法组件中的一个函数,用于计算某个序列局部元素的和。它有多个重载函数,可以根据需要选择适合的函数来使用。要使用partial_sum函数,需要引用头文件numeric。partial_sum函数的定义在numeric头文件中,它有两种语法格式:OutputIterator partial_sum (InputIterator first, InputIterator last, OutputIterator result)和OutputIterator partial_sum (InputIterator first, InputIterator last, OutputIterator result, BinaryOperation binary_op)。<span class="em">1</span><span class="em">2</span><span class="em">3</span> #### 引用[.reference_title] - *1* [udimanber add(y,i) partial_sum(i)](https://download.csdn.net/download/mostovoi1234/2986350)[target="_blank" data-report-click={"spm":"1018.2226.3001.9630","extra":{"utm_source":"vip_chatgpt_common_search_pc_result","utm_medium":"distribute.pc_search_result.none-task-cask-2~all~insert_cask~default-1-null.142^v93^chatsearchT3_1"}}] [.reference_item style="max-width: 33.333333333333336%"] - *2* [partial_sum 的使用](https://blog.csdn.net/weixin_44566320/article/details/91355171)[target="_blank" data-report-click={"spm":"1018.2226.3001.9630","extra":{"utm_source":"vip_chatgpt_common_search_pc_result","utm_medium":"distribute.pc_search_result.none-task-cask-2~all~insert_cask~default-1-null.142^v93^chatsearchT3_1"}}] [.reference_item style="max-width: 33.333333333333336%"] - *3* [partial_sum函数用法](https://blog.csdn.net/Albdon/article/details/119993932)[target="_blank" data-report-click={"spm":"1018.2226.3001.9630","extra":{"utm_source":"vip_chatgpt_common_search_pc_result","utm_medium":"distribute.pc_search_result.none-task-cask-2~all~insert_cask~default-1-null.142^v93^chatsearchT3_1"}}] [.reference_item style="max-width: 33.333333333333336%"] [ .reference_list ]
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值