Multiplication Puzzle (区间dp)

The multiplication puzzle is played with a row of cards, each containing a single positive integer. During the move player takes one card out of the row and scores the number of points equal to the product of the number on the card taken and the numbers on the cards on the left and on the right of it. It is not allowed to take out the first and the last card in the row. After the final move, only two cards are left in the row.

The goal is to take cards in such order as to minimize the total number of scored points.

For example, if cards in the row contain numbers 10 1 50 20 5, player might take a card with 1, then 20 and 50, scoring
10*1*50 + 50*20*5 + 10*50*5 = 500+5000+2500 = 8000

If he would take the cards in the opposite order, i.e. 50, then 20, then 1, the score would be
1*50*20 + 1*20*5 + 10*1*5 = 1000+100+50 = 1150.
Input
The first line of the input contains the number of cards N (3 <= N <= 100). The second line contains N integers in the range from 1 to 100, separated by spaces.
Output
Output must contain a single integer - the minimal score.
Sample Input
6
10 1 50 50 20 5
Sample Output
3650

题意:在数组中删除一个数arr[i],会得到一个分数,其值为arr[ i ]*arr[i-1]*arr[i+1]

要把除第一个和最后一个的数字删除,所得分数为每次得分的总和,求最小值

思路:区间dp,dp[ l ][ r ]表示删除 l+1~r-1  的数字所得到的最小值

代码一:

#include<stdio.h>
#include<string.h>
#include<algorithm>
#define Inf 0x3f3f3f3f
using namespace std;
const int N = 110;
int arr[N],dp[N][N];
int solve(int l,int r){
	if(dp[l][r]!=Inf) return dp[l][r];
	if(r==l+1) return dp[l][r]=0;
	for(int k=l+1;k<r;k++)
	   dp[l][r]=min(dp[l][r],arr[k]*arr[l]*arr[r]+solve(l,k)+solve(k,r));
	return dp[l][r];
}
int main(){
	int n;
	scanf("%d",&n);
	for(int i=0;i<n;i++)
	   scanf("%d",&arr[i]);
    memset(dp,Inf,sizeof(dp));
    printf("%d\n",solve(0,n-1));
	return 0;
}

代码二:

#include<stdio.h>
#include<string.h>
#include<algorithm>
#define Inf 0x3f3f3f3f
using namespace std;
const int N = 110;
int dp[N][N],arr[N];
int main(){
	int n;
	scanf("%d",&n);
	for(int i=1;i<=n;i++)
	   scanf("%d",&arr[i]);
	for(int len=2;len<=n;len++){
		for(int l=2,r;(r=l+len-1)<=n;l++){
			dp[l][r]=Inf;
			for(int k=l;k<r;k++)
			   dp[l][r]=min(dp[l][r],dp[l][k]+dp[k+1][r]+arr[l-1]*arr[k]*arr[r]);
		}
	}
	printf("%d\n",dp[2][n]);
	return 0;
}
  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值