Watchcow(Fleuryu打印欧拉路径 )

Bessie's been appointed the new watch-cow for the farm. Every night, it's her job to walk across the farm and make sure that no evildoers are doing any evil. She begins at the barn, makes her patrol, and then returns to the barn when she's done.

If she were a more observant cow, she might be able to just walk each of M (1 <= M <= 50,000) bidirectional trails numbered 1..M between N (2 <= N <= 10,000) fields numbered 1..N on the farm once and be confident that she's seen everything she needs to see. But since she isn't, she wants to make sure she walks down each trail exactly twice. It's also important that her two trips along each trail be in opposite directions, so that she doesn't miss the same thing twice.

A pair of fields might be connected by more than one trail. Find a path that Bessie can follow which will meet her requirements. Such a path is guaranteed to exist.

Input

* Line 1: Two integers, N and M.

* Lines 2..M+1: Two integers denoting a pair of fields connected by a path.

Output

* Lines 1..2M+1: A list of fields she passes through, one per line, beginning and ending with the barn at field 1. If more than one solution is possible, output any solution.

Sample Input

4 5
1 2
1 4
2 3
2 4
3 4

Sample Output

1
2
3
4
2
1
4
3
2
4
1

Hint

OUTPUT DETAILS:

Bessie starts at 1 (barn), goes to 2, then 3, etc...

题意:已知一共有n个点,m条边的图,要求每条路恰好往返各走一次,

打印路过的所有点。

思路:Fleury算法求解欧拉路径,Fleury算法详解

#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
const int N = 1e4+5;
struct node{
	int u,v;
	int able;
	int next;
}edge[N*10];
int head[N],id;
int sta[N*20],top;
int n,m;
void init(){
	top=id=0;
	memset(head,-1,sizeof(head));
}
void add(int u,int v){
	edge[id].u=u;
	edge[id].v=v;
	edge[id].able=1;
	edge[id].next=head[u];
    head[u]=id++;
}
void DFS(int u){
	sta[top++]=u;
	for(int i=head[u];i!=-1;i=edge[i].next){
		int v=edge[i].v;
		if(edge[i].able){
			edge[i].able=0;
			DFS(v);
			break;
		}
	}
}
void fleury(int s){
	sta[top++]=s;
	int brdge;
	while(top>0){
		brdge=1;
		int u=sta[top-1];
		for(int i=head[u];i!=-1;i=edge[i].next){
			int v=edge[i].v;
			if(edge[i].able){
				brdge=0;
				break;
			}
		}
		if(brdge) printf("%d\n",sta[--top]);
		else DFS(sta[--top]);
	}
}
int main(){
	while(~scanf("%d%d",&n,&m)){
		init();
		for(int i=0;i<m;i++){
			int u,v;
			scanf("%d%d",&u,&v);
			add(u,v);
			add(v,u);
		}
		fleury(1);
	}
	return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值