PAT (Advanced Level) Practice 1025 PAT Ranking (25 分)

1025 PAT Ranking (25 分)

Programming Ability Test (PAT) is organized by the College of Computer Science and Technology of Zhejiang University. Each test is supposed to run simultaneously in several places, and the ranklists will be merged immediately after the test. Now it is your job to write a program to correctly merge all the ranklists and generate the final rank.

Input Specification:

Each input file contains one test case. For each case, the first line contains a positive number N (≤100), the number of test locations. Then N ranklists follow, each starts with a line containing a positive integer K (≤300), the number of testees, and then K lines containing the registration number (a 13-digit number) and the total score of each testee. All the numbers in a line are separated by a space.

Output Specification:

For each test case, first print in one line the total number of testees. Then print the final ranklist in the following format:

registration_number final_rank location_number local_rank

The locations are numbered from 1 to N. The output must be sorted in nondecreasing order of the final ranks. The testees with the same score must have the same rank, and the output must be sorted in nondecreasing order of their registration numbers.

Sample Input:

2
5
1234567890001 95
1234567890005 100
1234567890003 95
1234567890002 77
1234567890004 85
4
1234567890013 65
1234567890011 25
1234567890014 100
1234567890012 85

Sample Output:

9
1234567890005 1 1 1
1234567890014 1 2 1
1234567890001 3 1 2
1234567890003 3 1 2
1234567890004 5 1 4
1234567890012 5 2 2
1234567890002 7 1 5
1234567890013 8 2 3
1234567890011 9 2 4

Code:

#include <iostream>
#include <vector>
#include <algorithm>
#include <string>
#pragma warning(disable:4996)

using namespace std;

struct Node
{
	string id;
	int score;
	int fr, lc, lr;
	Node() :score(-1) {}
	bool operator < (const Node& n1) const
	{
		return (this->score == n1.score) ? (this->id < n1.id) : (this->score > n1.score);
	}
};

void Rank(vector<Node>& v, bool but) // 0 for lr, 1 for fr
{
	Node pre; int rank = 0, cnt = 1;
	if (but == 0)
	{
		for (int i=0; i<v.size(); i++)
		{
			if (v[i].score != pre.score)
			{
				v[i].lr = rank + cnt;
				rank = v[i].lr;
				cnt = 1;
				pre.score = v[i].score;
			}
			else
			{
				v[i].lr = rank;
				cnt++;
			}
		}
	}
	else if (but == 1)
	{
		for (int i = 0; i<v.size(); i++)
		{
			if (v[i].score != pre.score)
			{
				v[i].fr = rank + cnt;
				rank = v[i].fr;
				cnt = 1;
				pre.score = v[i].score;
			}
			else
			{
				v[i].fr = rank;
				cnt++;
			}
		}
	}
}

int main()
{
	int N;
	scanf("%d", &N);
	vector<Node> final_rank;
	vector<Node> local_rank;
	for (int c = 1; c <= N; c++)
	{
		int K;
		scanf("%d", &K);
		for (int i = 0; i < K; i++)
		{
			Node temp; string t1; int s1;
			cin >> t1 >> s1;
			temp.id = t1; temp.score = s1; temp.lc = c;
			local_rank.push_back(temp);
		}
		sort(local_rank.begin(), local_rank.end());
		Rank(local_rank, 0);
		for (int i = 0; i < local_rank.size(); i++)
			final_rank.push_back(local_rank[i]);
		local_rank.clear();
	}
	sort(final_rank.begin(), final_rank.end());
	Rank(final_rank, 1);
	printf("%d\n", final_rank.size());
	for (auto it : final_rank)
	{
		cout << it.id;
		printf(" %d %d %d\n", it.fr, it.lc, it.lr);
	}
	return 0;
}

思路:

构建数据结构Node,自定义<,把分数高,ID小的Node排在前面,用Rank函数赋总排名和考场排名。
注意自定义数据结构<,一定要是常函数。下面是模板。

struct A 
{
	//........
	bool operator < (const A& a1) const/*重要*/{
		//............
	}
};

2019.1.4更新


void Rank(vector<Node>& vec, bool but)
{
	if (but == 0)
	{
		vec[0].lr = 1;
		for (int i = 1; i < vec.size(); i++)
		{
			if (vec[i].score == vec[i - 1].score)
				vec[i].lr = vec[i - 1].lr;
			else
				vec[i].lr = i + 1;
		}
	}
	else if (but == 1)
	{
		vec[0].fr = 1;
		for (int i = 1; i < vec.size(); i++)
		{
			if (vec[i].score == vec[i - 1].score)
				vec[i].fr = vec[i - 1].fr;
			else
				vec[i].fr = i + 1;
		}
	}
}

短的Rank算法,来自晴神宝典
在这里插入图片描述在这里插入图片描述

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值