PAT (Advanced Level) 1032 Sharing (25 分)

1032 Sharing (25 分)

To store English words, one method is to use linked lists and store a word letter by letter. To save some space, we may let the words share the same sublist if they share the same suffix. For example, loading and being are stored as showed in Figure 1.
在这里插入图片描述
Figure 1
You are supposed to find the starting position of the common suffix (e.g. the position of i in Figure 1).

Input Specification:

Each input file contains one test case. For each case, the first line contains two addresses of nodes and a positive N (≤10​5​​), where the two addresses are the addresses of the first nodes of the two words, and N is the total number of nodes. The address of a node is a 5-digit positive integer, and NULL is represented by −1.
Then N lines follow, each describes a node in the format:

Address Data Next

whereAddress is the position of the node, Data is the letter contained by this node which is an English letter chosen from { a-z, A-Z }, and Next is the position of the next node.

Output Specification:

For each case, simply output the 5-digit starting position of the common suffix. If the two words have no common suffix, output -1 instead.

Sample Input 1:

11111 22222 9
67890 i 00002
00010 a 12345
00003 g -1
12345 D 67890
00002 n 00003
22222 B 23456
11111 L 00001
23456 e 67890
00001 o 00010

Sample Output 1:

67890

Sample Input 2:

00001 00002 4
00001 a 10001
10001 s -1
00002 a 10002
10002 t -1

Sample Output 2:

-1

Code:

#include <iostream>
#include <map>
#pragma warning(disable:4996)

using namespace std;

struct Node
{
	char ch;
	bool isLinked = false;
	int next;
	Node(){}
	Node(char c, int n): ch(c), next(n){}
};

Node id_node[100000];

int main()
{
	int h1, h2, num;
	scanf("%d%d%d", &h1, &h2, &num);	
	for (int i = 0; i < num; i++)
	{
		int id, next;
		char ch;
		scanf("%d %c %d", &id, &ch, &next);
		id_node[id] = Node(ch, next);
	}
	for (int curr = h1; curr != -1; curr = id_node[curr].next)
		id_node[curr].isLinked = true;
	for (int curr = h2; curr != -1; curr = id_node[curr].next)
		if (id_node[curr].isLinked)
		{
			printf("%05d\n", curr);
			return 0;
		}
	printf("-1\n");
	return 0;
}

思路

用Node数组存放所有节点,如果用map<int, Node>会在一个测试点上超时,因为组织map还需要根据键值排序,在这道题目中是不需要的,然后遍历第一条链,把所有遍历过的节点打标,再遍历第二条链,查看,每个节点是否被遍历过。
注意:

  1. 输出的时候应该是printf("%05d", curr)不是仅仅printf("%d", curr)因为curr=1需要输出00001。
  2. scanf的时候需要scanf("%d %c %d", &XX, &XX, &XX)而不是scanf("%d%c%d", &XX, &XX, &XX),我需要去学一下printf和scanf。。。
    遍历方法美化,这里使用了,柳婼大佬的优雅遍历法
for (int curr = h1; curr != -1; curr = id_node[curr].next)
		id_node[curr].isLinked = true;

代替我的

int curr = h1
while(true)
{
	id_node[curr].isLinked = true;
	if(id_node[curr].next == -1) break;
	else curr = id_node[curr].next;
}

以上

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值