PAT (Advanced Level) 1119 Pre- and Post-order Traversals (30 分)

1119 Pre- and Post-order Traversals (30 分)

Suppose that all the keys in a binary tree are distinct positive integers. A unique binary tree can be determined by a given pair of postorder and inorder traversal sequences, or preorder and inorder traversal sequences. However, if only the postorder and preorder traversal sequences are given, the corresponding tree may no longer be unique.
Now given a pair of postorder and preorder traversal sequences, you are supposed to output the corresponding inorder traversal sequence of the tree. If the tree is not unique, simply output any one of them.

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (≤ 30), the total number of nodes in the binary tree. The second line gives the preorder sequence and the third line gives the postorder sequence. All the numbers in a line are separated by a space.

Output Specification:

For each test case, first printf in a line Yes if the tree is unique, or No if not. Then print in the next line the inorder traversal sequence of the corresponding binary tree. If the solution is not unique, any answer would do. It is guaranteed that at least one solution exists. All the numbers in a line must be separated by exactly one space, and there must be no extra space at the end of the line.

Sample Input 1:

7
1 2 3 4 6 7 5
2 6 7 4 5 3 1

Sample Output 1:

Yes
2 1 6 4 7 3 5

Sample Input 2:

4
1 2 3 4
2 4 3 1

Sample Output 2:

No
2 1 3 4

Code:

#include <iostream>
#include <vector>
#pragma warning(disable:4996)

using namespace std;

vector<int> pre, in, pos;
bool isUnique = true;

void inOrder(int preL, int preR, int posL, int posR)
{
	if (preL == preR) // 叶子节点
	{
		in.push_back(pre[preL]);
		return;
	}
	if (pre[preL] == pos[posR]) // 找到根节点R
	{
		int i = preL + 1;
		while (i <= preR && pre[i] != pos[posR - 1]) i++;
		if (i - preL > 1)
			inOrder(preL + 1, i - 1, posL, posL + (i - preL - 1) - 1); //处理R的左子数
		else
			isUnique = false;
		in.push_back(pos[posR]); //输出R
		inOrder(i, preR, posL + (i - preL - 1), posR - 1); //处理R的右子树
	}
}

int main()
{
	int n;
	scanf("%d", &n);
	pre.resize(n); pos.resize(n);
	for (int i = 0; i < n; i++)
		scanf("%d", &pre[i]);
	for (int i = 0; i < n; i++)
		scanf("%d", &pos[i]);
	inOrder(0, n - 1, 0, n - 1);
	cout << (isUnique ? "Yes\n" : "No\n");
	for (int i = 0; i < in.size(); i++)
		printf("%d%c", in[i], (i == in.size() - 1 ? '\n' : ' '));
	return 0;
}

思路:

当一棵二叉树通过先序数列和后序数列不能唯一确定时,它至少有一个节点只有一个孩子,而这个孩子无法确定其是左孩子还是右孩子。
对于一棵二叉树 ,先序序列[preL, preR],后序序列[posL, posR]。这棵二叉树的根节点一定是pre[preL],也就是pos[posR],pre[preL+1]和pos[posR-1]一定是这个根节点的某一子树,如果这个节点既有左子数又有右子树,那么pre[preL+1]是左子树,pos[posR-1]是右子树。所以通过 i 找到pre[i] = pos[posR -1]的索引,如果i=preL+1那么就说明这个节点只有一个孩子,所以这棵二叉树无法唯一确定。
接下来中序遍历的递归区间就是(这里是左闭右闭区间)
左子树(先序左端,先序左端 + 左子树节点树, 后序左端,后序左端 + 左子树节点数)
右子树(先序左端,先序左端 + 右子树节点树, 后序左端,后序左端 + 右子树节点数)

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值