Anti-prime Sequences(DFS + 素数筛选)

Anti-prime Sequences
Time Limit: 3000MS  Memory Limit: 30000K
Total Submissions: 2790  Accepted: 1288

Description

Given a sequence of consecutive integers n,n+1,n+2,...,m, an anti-prime sequence is a rearrangement of these integers so that each adjacent pair of integers sums to a composite (non-prime) number. For example, if n = 1 and m = 10, one such anti-prime sequence is 1,3,5,4,2,6,9,7,8,10. This is also the lexicographically first such sequence. 

We can extend the definition by defining a degree danti-prime sequence as one where all consecutive subsequences of length 2,3,...,d sum to a composite number. The sequence above is a degree 2 anti-prime sequence, but not a degree 3, since the subsequence 5, 4, 2 sums to 11. The lexicographically .rst degree 3 anti-prime sequence for these numbers is 1,3,5,4,6,2,10,8,7,9. 

Input

Input will consist of multiple input sets. Each set will consist of three integers, n, m, and d on a single line. The values of n, m and d will satisfy 1 <= n < m <= 1000, and 2 <= d <= 10. The line 0 0 0 will indicate end of input and should not be processed.

Output

For each input set, output a single line consisting of a comma-separated list of integers forming a degree danti-prime sequence (do not insert any spaces and do not split the output over multiple lines). In the case where more than one anti-prime sequence exists, print the lexicographically first one (i.e., output the one with the lowest first value; in case of a tie, the lowest second value, etc.). In the case where no anti-prime sequence exists, output 

No anti-prime sequence exists. 

Sample Input

1 10 2
1 10 3
1 10 5
40 60 7
0 0 0

Sample Output

1,3,5,4,2,6,9,7,8,10
1,3,5,4,6,2,10,8,7,9
No anti-prime sequence exists.
40,41,43,42,44,46,45,47,48,50,55,53,52,60,56,49,51,59,58,57,54

 

    题意:

    给出 n(1 ~ 1000),m(1 ~ 1000),d(1 ~ 10)。要求重新排列 N 到 M 这个序列,排列的要求是任意连续 i (i <= d)个数的和都必须是合数,有则输出这个序列。

 

    思路:

    DFS + 素数筛选。搜的同时记录总和。素数要求筛选知道要到 1000 * 10 = 10000 而不是 1005,因此而WA了 N 遍。

 

    AC:

#include <cstdio>
#include <string.h>
#define MAX 10005
using namespace std;

int n,m,d,ans,temp;
bool pri[MAX],vis[1005];
int fin[1005],sum[1005];

void make_pri() {
    for(int i = 0;i < MAX;i++) pri[i] = true;
    pri[0] = pri[1] = false;

    for(int i = 2;i * i < MAX;++i)
            if(pri[i]) {
                    for(int j = i;i * j < MAX;++j)
                            pri[i * j] = false;
            }
}

void dfs(int time,int val) {
    vis[val] = false;
    fin[time] = val;
    if(time) sum[time] = sum[time - 1] + val;
    if(temp) return;

    if(time >= 2) {
            int to = time <= d ? 0 : time - d;
                    for(int i = time - 2 ;i >= to;i--) {
                            int a = sum[time] - sum[i];
                            if(pri[a]) return;
                    }
    }

    if(time == ans) {
            temp = 1;
            for(int i = 1;i <= time;i++) {
                    printf("%d",fin[i]);
                    i == time ? printf("\n") : printf(",");
            }
            return;
    }

    for (int i = n;i <= m;i++) {
            if (vis[i] && !temp) {
                    dfs(time + 1,i);
                    vis[i] = true;
            }
    }
}

int main() {
    make_pri();

    while(~scanf("%d%d%d",&n,&m,&d) && (n + m + d)) {
            ans = m - n + 1;
            temp = 0;
            for(int i = n;i <= m;i++) vis[i] = true;
            dfs(0,0);
            if(!temp) puts("No anti-prime sequence exists.");
    }

    return 0;
}

 

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值