HDU 1165 Eddy's research II(递推)

Problem Description
As is known, Ackermann function plays an important role in the sphere of theoretical computer science. However, in the other hand, the dramatic fast increasing pace of the function caused the value of Ackermann function hard to calcuate.

Ackermann function can be defined recursively as follows:


Now Eddy Gives you two numbers: m and n, your task is to compute the value of A(m,n) .This is so easy problem,If you slove this problem,you will receive a prize(Eddy will invite you to hdu restaurant to have supper).
 

Input
Each line of the input will have two integers, namely m, n, where 0 < m < =3.
Note that when m<3, n can be any integer less than 1000000, while m=3, the value of n is restricted within 24. 
Input is terminated by end of file.
 

Output
For each value of m,n, print out the value of A(m,n).
 

Sample Input
  
  
1 3 2 4
 

Sample Output
  
  
5 11

思路:

刚开始想直接找公式发现有点难,后来想了想这是dp小练啊,先从最简单的一个个开始推,果然找到了规律。

以n为行,m为列,画表。

n==1时,A(1,0)=2,A(1,M)=A(1 , A(M-1) ),所以每一项都是前一项结果+1.


n==2时,A(2,0)=A(1,1)=3,A(2,M)=A(1, A( 2 , M-1) ),可得公式A(2,M)=2*M+3.


n==3时,A(3,0)=A(2,1)=5,A(3,M)=A(2 , A(3 , M-1) ),可得公式A(3,M)=5+8*(2^M-1).


代码:

#include<stdio.h>

int super_pow(int a)
{
    int ans=1,n=2;
    while(a)
    {
        if(a&1)ans*=n;
        n*=n;
        a>>=1;
    }
    return ans;
}

int main()
{
    int n,m;
    while(~scanf("%d%d",&n,&m))
    {
        if(n==1)printf("%d\n",m+2);
        if(n==2)printf("%d\n",2*m+3);
        if(n==3)printf("%d\n",5+8*(super_pow(m)-1));
    }
	return 0;
}


评论 2
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值