hdu Eddy's research II(递推,找规律,打表)

115 篇文章 0 订阅
60 篇文章 1 订阅
Eddy's research II
Problem Description
As is known, Ackermann function plays an important role in the sphere of theoretical computer science. However, in the other hand, the dramatic fast increasing pace of the function caused the value of Ackermann function hard to calcuate.

Ackermann function can be defined recursively as follows:


Now Eddy Gives you two numbers: m and n, your task is to compute the value of A(m,n) .This is so easy problem,If you slove this problem,you will receive a prize(Eddy will invite you to hdu restaurant to have supper).
 

Input
Each line of the input will have two integers, namely m, n, where 0 < m < =3.
Note that when m<3, n can be any integer less than 1000000, while m=3, the value of n is restricted within 24. 
Input is terminated by end of file.
 

Output
For each value of m,n, print out the value of A(m,n).
 

Sample Input
   
   
1 3 2 4
 

Sample Output
   
   
5 11
递推找规律代码:
#include<stdio.h>
int dp[4][1000010];
int dfs(int m,int n)
{
    if(dp[m][n])
        return dp[m][n];
    if(m==0)
        return n+1;
    if(n==0&&m>0)
        return dfs(m-1,1);
    if(n>0&&m>0)
        return dfs(m-1,dfs(m,n-1));
}
int main()
{
    int m,n;
    while(~scanf("%d%d",&m,&n))
    {
        int ans=dfs(m,n);
        printf("%d\n",ans);
    }
    return 0;
}

打表代码:
#include<stdio.h>
#define N 1000010
int dp[4][N];
void A()
{
    int i;
    for(i=1; i<N; i++)
        dp[1][i]=dp[1][i-1]+1;
    for(i=1; i<N; i++)
        dp[2][i]=dp[2][i-1]+2;
    for(i=1; i<=24; i++)
        dp[3][i]=dp[3][i-1]+(1<<(i+2));
}
int main()
{
    dp[1][0]=2;
    dp[2][0]=3;
    dp[3][0]=5;
    A();
    int m,n;
    while(~scanf("%d%d",&m,&n))
    {
        printf("%d\n",dp[m][n]);
    }
    return 0;
}


  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值