2017ICPC北京 J:Pangu and Stones(区间DP)

时间限制: 1000ms
单点时限: 1000ms
内存限制: 256MB

描述

In Chinese mythology, Pangu is the first living being and the creator of the sky and the earth. He woke up from an egg and split the egg into two parts: the sky and the earth.

At the beginning, there was no mountain on the earth, only stones all over the land.

There were N piles of stones, numbered from 1 to N. Pangu wanted to merge all of them into one pile to build a great mountain. If the sum of stones of some piles was S, Pangu would need S seconds to pile them into one pile, and there would be S stones in the new pile.

Unfortunately, every time Pangu could only merge successive piles into one pile. And the number of piles he merged shouldn't be less than L or greater than R.

Pangu wanted to finish this as soon as possible.

Can you help him? If there was no solution, you should answer '0'.

输入

There are multiple test cases.

The first line of each case contains three integers N,L,R as above mentioned (2<=N<=100,2<=L<=R<=N).

The second line of each case contains N integers a1,a2 …aN (1<= ai  <=1000,i= 1…N ), indicating the number of stones of  pile 1, pile 2 …pile N.

The number of test cases is less than 110 and there are at most 5 test cases in which N >= 50.

输出

For each test case, you should output the minimum time(in seconds) Pangu had to take . If it was impossible for Pangu to do his job, you should output  0.

样例输入
3 2 2
1 2 3
3 2 3
1 2 3
4 3 3
1 2 3 4
样例输出
9
6
0


题意:

n个石子堆排成一排,每次可以将连续的最少L堆,最多R堆石子合并在一起,消耗的代价为要合并的石子总数

求合并成1堆的最小代价,如果无法做到输出0


思路:

dp[i][j][k]表示区间[i, j]分成k堆的最小代价,转移有

k=1时:

dp[i][j][1] = min(dp[i][p][x-1]+dp[p+1][j][1]+sum[i][j] (i<=p<=j-1;L<=x<=R) )

k>1时:

dp[i][j][k] = min(dp[i][p][k-1]+dp[p+1][j][1] ( i<=p<=j-1) )


// 2017ICPC北京
#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;
#define LL long long
int a[105], sum[105][105];
LL dp[105][105][105];
int main(void)
{
	int i, j, k, p, n, l, r;
	while(scanf("%d%d%d", &n, &l, &r)!=EOF)
	{
		for(i=1;i<=n;i++)
			scanf("%d", &a[i]);
		memset(dp, 62, sizeof(dp));
		for(i=1;i<=n;i++)
		{
			sum[i][i-1] = 0;
			for(j=i;j<=n;j++)
			{
				sum[i][j] = sum[i][j-1]+a[j];
				dp[i][j][j-i+1] = 0;
			}
		}
		for(i=1;i<=n;i++)
		{
			for(j=i;j<=n;j++)
				dp[i][j][j-i+1] = 0;
		}
		for(p=1;p<=n-1;p++)
		{
			for(i=1;i+p<=n;i++)
			{
				for(j=i;j<=i+p-1;j++)
				{
					for(k=l-1;k<=r-1;k++)
						dp[i][i+p][1] = min(dp[i][i+p][1], dp[i][j][k]+dp[j+1][i+p][1]+sum[i][i+p]);
				}
				for(j=2;j<=p;j++)
				{
					for(k=i;k<=i+p-1;k++)
						dp[i][i+p][j] = min(dp[i][i+p][j], dp[i][k][j-1]+dp[k+1][i+p][1]);
				}
			}
		}
		if(dp[1][n][1]==4485090715960753726ll)
			printf("0\n");
		else
			printf("%lld\n", dp[1][n][1]);
	}
	return 0;
}
/*
2 1 1
1 2
*/

  • 1
    点赞
  • 3
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值