Where is the Marble? Uva_10474 ——最为简单的排序和检索

Raju and Meena love to play with Marbles. They have got a lot ofmarbles with numbers written on them. At the beginning, Raju wouldplace the marbles one after another in ascending order of the numberswritten on them. Then Meena would ask Raju to find the first marblewith a certain number. She would count 1...2...3. Raju gets one pointfor correct answer, and Meena gets the point if Raju fails. After somefixed number of trials the game ends and the player with maximumpoints wins. Today it’s your chance to play as Raju. Being the smartkid, you’d be taking the favor of a computer. But don’t underestimateMeena, she had written a program to keep track how much time you’retaking to give all the answers. So now you have to write a program,which will help you in your role as Raju.

Input

There can be multiple test cases. Total no of test cases is less than 65. Each test case consists beginswith 2 integers: N the number of marbles and Q the number of queries Mina would make. The nextN lines would contain the numbers written on the N marbles. These marble numbers will not comein any particular order. Following Q lines will have Q queries. Be assured, none of the input numbersare greater than 10000 and none of them are negative.

Input is terminated by a test case where N = 0 and Q = 0.

Output

For each test case output the serial number of the case.
For each of the queries, print one line of output. The format of this line will depend upon whether

or not the query number is written upon any of the marbles. The two different formats are describedbelow:

x found at y’, if the first marble with number x was found at position y. Positions are numbered1,2,...,N.

x not found’, if the marble with number x is not present.Look at the output for sample input for details.

Sample Input

4 1

2
3
5

1

5

5 2

1

3
3
3
1
2
3

0 0

Sample Output

CASE# 1:
5 found at 4
CASE# 2:
2 not found
3 found at 3


本题分析:具体也没啥好分析的...读得懂题就能做出来...

这里小声逼逼几句,是关于这道题书上代码的学习的......


#include<iostream>
#include<cstdio>
#include<algorithm>
using namespace std;

const int maxn = 10000;

int main(){
    int n, q, x, a[maxn], kase = 0;
    while(scanf("%d%d", &n, &q) == 2 && n)
    {
        printf("CASE# %d:\n", ++kase);
        for(int i = 0; i < n; i++)
            scanf("%d", &a[i]);
        sort(a, a + n);
        while(q--)
        {
            scanf("%d", &x);
            int p = lower_bound(a, a+n, x) - a;//在已排序数组a中寻找x
            if(a[p] == x)
                printf("%d found at %d\n", x, p + 1);
            else 
                printf("%d not found\n", x);
        }
    }
	return 0;
}

1、如果碰到对输出有要求的(就像这道题一样要求输出组号),那么最好先进行输出。

2、while(scanf("%d%d", &n, &q) == 2 && n)的用法

3、while(q--)完全是一种简单的循环的使用方法,可以不要再用for了哦~


知识点复习:

  • sort使用数组元素默认的大小比较运算符进行排序。
  • 如果希望用sort排序,那么这个类型需要定义“小于”运算符,或者在排序时传入一个“小于”函数。
  • 排序对象可以存在于普通数组里,也可以存在于vector中。数组使用sort(a, a+n)的方式调用,vector用sort(v.begin(), v.end())的方式调用。
  • lower_bound的作用是:查找“大于或者等于x的第一个位置”


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值