sumsets(poj2229)

Language:
Sumsets
Time Limit: 2000MS Memory Limit: 200000K
Total Submissions: 16489 Accepted: 6516

Description

Farmer John commanded his cows to search for different sets of numbers that sum to a given number. The cows use only numbers that are an integer power of 2. Here are the possible sets of numbers that sum to 7: 

1) 1+1+1+1+1+1+1 
2) 1+1+1+1+1+2 
3) 1+1+1+2+2 
4) 1+1+1+4 
5) 1+2+2+2 
6) 1+2+4 

Help FJ count all possible representations for a given integer N (1 <= N <= 1,000,000). 

Input

A single line with a single integer, N.

Output

The number of ways to represent N as the indicated sum. Due to the potential huge size of this number, print only last 9 digits (in base 10 representation).

Sample Input

7

Sample Output

6
这道题并不算难,但是第一次提交却WA(Wrong Answer),原因是没有认真读题,题目要求有print only last 9 digits (in base 10 representation).
     
     
结果就WA,搜了题解才发现自己好傻。。。
用dp[i]表示和为i的种类数。则有:如果i为奇数,dp[i]=dp[i-1];如果i为偶数,可以选1,也可以不选1(01背包问题的思想),选1,i-1为奇数可根据递推式求出;不选1,全为偶数,则有dp[i/2]种,即dp[i]=dp[i-1]+dp[i/2];
总之,dp[i]=dp[i-1](i为奇数)。dp[i]=dp[i-1]+dp[i/2](i为偶数)。
AC代码如下:
#include<iostream>
using namespace std;
int dp[1000005];
int n;
void solve()
{
                dp[0]=1;
                for(int i=1;i<=n;i++){
                                if(i%2) dp[i]=dp[i-1];
                                else dp[i]=(dp[i-1]+dp[i/2])%1000000000;
                }
                cout<<dp[n]<<endl;
}
int main()
{

                cin>>n;
                solve();
                return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值