POJ2299Ultra-QuickSort逆序对裸题

易水人去,明月如霜。

Description

In this problem, you have to analyze a particular sorting algorithm. The algorithm processes a sequence of n distinct integers by swapping two adjacent sequence elements until the sequence is sorted in ascending order. For the input sequence
9 1 0 5 4 ,

Ultra-QuickSort produces the output
0 1 4 5 9 .

Your task is to determine how many swap operations Ultra-QuickSort needs to perform in order to sort a given input sequence.

Input

The input contains several test cases. Every test case begins with a line that contains a single integer n < 500,000 -- the length of the input sequence. Each of the the following n lines contains a single integer 0 ≤ a[i] ≤ 999,999,999, the i-th input sequence element. Input is terminated by a sequence of length n = 0. This sequence must not be processed.

Output

For every input sequence, your program prints a single line containing an integer number op, the minimum number of swap operations necessary to sort the given input sequence.

Sample Input

5
9
1
0
5
4
3
1
2
3
0

Sample Output

6
0
求逆序对

#include<iostream>
#include<algorithm>
#include<cstdio>
#include<cstring>
using namespace std;
int read()
{
    char ch;int s=0,f=1;
    ch=getchar();
    while(ch>'9'||ch<'0'){ if(ch=='-') f*=-1;ch=getchar(); }
    while(ch>='0'&&ch<='9') { s=s*10+ch-48; ch=getchar();}
   return s*f;
}

long long num[500005];
long long temp[500005];
int n;
long long ans;
int merge(int l,int mid,int r)
{
    int i=l,k=l,j=mid+1;
    while(i<=mid&&j<=r)
    {
        if(num[i]<=num[j])
        {
            temp[k++]=num[i++];
        }
        else {
            ans+=(j-k);
            temp[k++]=num[j++];
        }
    }
    while(i<=mid) temp[k++]=num[i++];
    while(j<=r) temp[k++]=num[j++];
    for(int z=l;z<=r;z++) num[z]=temp[z];

}
int sor(int a,int b)
{
    if(a<b)
    {
        int mid=a+(b-a)/2;
        sor(a,mid);sor(mid+1,b);
        merge(a,mid,b);
    }
}
int main()
{
while(scanf("%d",&n)&&n)
{
    for(int i=1;i<=n;i++)
      scanf("%d",&num[i]);
      ans=0;
      sor(1,n);
      printf("%lld\n",ans);

}
return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值