POJ - 1837 Balance 记忆化搜索,背包

Balance
Time Limit: 1000MS Memory Limit: 30000K
Total Submissions: 13998 Accepted: 8799

Description

Gigel has a strange "balance" and he wants to poise it. Actually, the device is different from any other ordinary balance. 
It orders two arms of negligible weight and each arm's length is 15. Some hooks are attached to these arms and Gigel wants to hang up some weights from his collection of G weights (1 <= G <= 20) knowing that these weights have distinct values in the range 1..25. Gigel may droop any weight of any hook but he is forced to use all the weights. 
Finally, Gigel managed to balance the device using the experience he gained at the National Olympiad in Informatics. Now he would like to know in how many ways the device can be balanced. 

Knowing the repartition of the hooks and the set of the weights write a program that calculates the number of possibilities to balance the device. 
It is guaranteed that will exist at least one solution for each test case at the evaluation. 

Input

The input has the following structure: 
• the first line contains the number C (2 <= C <= 20) and the number G (2 <= G <= 20); 
• the next line contains C integer numbers (these numbers are also distinct and sorted in ascending order) in the range -15..15 representing the repartition of the hooks; each number represents the position relative to the center of the balance on the X axis (when no weights are attached the device is balanced and lined up to the X axis; the absolute value of the distances represents the distance between the hook and the balance center and the sign of the numbers determines the arm of the balance to which the hook is attached: '-' for the left arm and '+' for the right arm); 
• on the next line there are G natural, distinct and sorted in ascending order numbers in the range 1..25 representing the weights' values. 

Output

The output contains the number M representing the number of possibilities to poise the balance.

Sample Input

2 4	
-2 3 
3 4 5 8

Sample Output

2

Source


想了半天想不出来。。。。。

http://blog.csdn.net/lyy289065406/article/details/6648094/    这篇题解写得很好

看完题解真的很巧妙

定义一个平衡度j=c[ i ] (挂的位置)* g[ i ](挂的物体重量)

通过平衡度出发去挂砝码,一层一层向下走

dp[ i ][ j ] 代表能到达这个状态的方法数,所以他也应该等于上一层里所有能通过挂上第 i 个砝码之后到达这个状态的方法数的和

dp [ i ] [ j ] = ∑ ( dp [ i - 1 ] [  j - c [ k ] * g [ i ] ] )

上面是通过上一层确定当前层,当然也可以在向下走的过程中,通过当前层确定下一层

由于平衡度可能是负数,所以把0平衡态右移,把7500当作平衡态,因为平衡态最小不会小于-7500  (20个重25的砝码全挂在-15的位置上 )

#include<stdio.h>
#include<string.h>
#include<math.h>
#include<string>
#include<algorithm>
#include<queue>
#include<vector>
#include<map>
#include<set>
typedef long long ll;
using namespace std;
int dp[3][5005];
int main()
{ 
	int i,j,n;
	char ch[5005],ch1[5005];
	scanf("%d",&n);
	getchar();
	scanf("%s",ch+1);
	for(i=1;i<=n;i++)
	ch1[n-i+1]=ch[i];
	for(i=1;i<=n;i++)
	{
		for(j=1;j<=n;j++)
		{
			if(ch[i]==ch1[j])
			{
				dp[1][j]=dp[0][j-1]+1;
			}
			else
			dp[1][j]=max(dp[0][j],dp[1][j-1]);
		}
		for(j=1;j<=n;j++)
		dp[0][j]=dp[1][j];
	}
	printf("%d\n",n-dp[1][n]);
	return 0; 
 }


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值