C - Can you answer these queries? HDU - 4027 线段树单点更新

Can you answer these queries?

Time Limit: 4000/2000 MS (Java/Others)    Memory Limit: 65768/65768 K (Java/Others)
Total Submission(s): 15096    Accepted Submission(s): 3540


Problem Description
A lot of battleships of evil are arranged in a line before the battle. Our commander decides to use our secret weapon to eliminate the battleships. Each of the battleships can be marked a value of endurance. For every attack of our secret weapon, it could decrease the endurance of a consecutive part of battleships by make their endurance to the square root of it original value of endurance. During the series of attack of our secret weapon, the commander wants to evaluate the effect of the weapon, so he asks you for help.
You are asked to answer the queries that the sum of the endurance of a consecutive part of the battleship line.

Notice that the square root operation should be rounded down to integer.
 

Input
The input contains several test cases, terminated by EOF.
  For each test case, the first line contains a single integer N, denoting there are N battleships of evil in a line. (1 <= N <= 100000)
  The second line contains N integers Ei, indicating the endurance value of each battleship from the beginning of the line to the end. You can assume that the sum of all endurance value is less than 2 63.
  The next line contains an integer M, denoting the number of actions and queries. (1 <= M <= 100000)
  For the following M lines, each line contains three integers T, X and Y. The T=0 denoting the action of the secret weapon, which will decrease the endurance value of the battleships between the X-th and Y-th battleship, inclusive. The T=1 denoting the query of the commander which ask for the sum of the endurance value of the battleship between X-th and Y-th, inclusive.
 

Output
For each test case, print the case number at the first line. Then print one line for each query. And remember follow a blank line after each test case.
 

Sample Input
  
  
10 1 2 3 4 5 6 7 8 9 10 5 0 1 10 1 1 10 1 1 5 0 5 8 1 4 8
 

Sample Output
  
  
Case #1: 19 7 6
 

Source
 

Recommend
lcy

单点更新

优化:1开根号还是1,更新时对于都是一个区间就不在更新

坑点:给的x,y不确定大小关系

#include<stdio.h>
#include<algorithm>
#include<string.h>
#include<queue>
#include<map>
#include<vector>
#include<iostream>
#include<math.h>
#define lson l,m,node<<1
#define rson m+1,r,node<<1|1
using namespace std;
const int maxn=100050;
long long int segtree[4*maxn];
int book[maxn*4];
int pushup(int node)
{
    segtree[node]=segtree[node<<1]+segtree[node<<1|1];
    book[node]=book[node<<1]&&book[node<<1|1];
}
int build(int l,int r,int node)
{
    if(l==r)
    {
        scanf("%lld",&segtree[node]);
        if(segtree[node]<=1)
            book[node]=1;
        return 0;
    }
    int m=(l+r)>>1;
    build(lson);
    build(rson);
    pushup(node);
    return 0;
}
int update(int le,int ri,int l,int r,int node)
{
    if(l==r)
    {
        segtree[node]=(long long)floor(sqrt(segtree[node]));
        if(segtree[node]<=1)
            book[node]=1;
        return 0;
    }
    if(book[node])
        return 0;
    int m=(l+r)>>1;
    if(le<=m)
        update(le,ri,lson);
    if(ri>m)
        update(le,ri,rson);
    pushup(node);
    return 0;
}
long long query(int le,int ri,int l,int r,int node)
{

    if(l>=le&&r<=ri)
        return segtree[node];
    long long int t1=0,t2=0;
    int m=(l+r)>>1;
    if(le<=m)
        t1=query(le,ri,lson);
    if(ri>m)
        t2=query(le,ri,rson);
    pushup(node);
    return t1+t2;
}
int main()
{
    int m,n,t,T=0,i,x,y;
    while(~scanf("%d",&n))
    {
        T++;
        memset(book,0,sizeof(book));
        build(1,n,1);
        scanf("%d",&m);
        printf("Case #%d:\n",T);
        while(m--)
        {
            scanf("%d %d %d",&t,&x,&y);
            if(x>y)
                x^=y^=x^=y;
            if(t==0)
            {
                update(x,y,1,n,1);
            }
            else if(t==1)
            {
                printf("%lld\n",query(x,y,1,n,1));
            }

        }
        printf("\n");
    }
    return 0;
}





  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值