poj 1611(并查集)

The Suspects
Time Limit: 1000MS Memory Limit: 20000K
Total Submissions: 14238 Accepted: 6761

Description

Severe acute respiratory syndrome (SARS), an atypical pneumonia of unknown aetiology, was recognized as a global threat in mid-March 2003. To minimize transmission to others, the best strategy is to separate the suspects from others. 
In the Not-Spreading-Your-Sickness University (NSYSU), there are many student groups. Students in the same group intercommunicate with each other frequently, and a student may join several groups. To prevent the possible transmissions of SARS, the NSYSU collects the member lists of all student groups, and makes the following rule in their standard operation procedure (SOP). 
Once a member in a group is a suspect, all members in the group are suspects. 
However, they find that it is not easy to identify all the suspects when a student is recognized as a suspect. Your job is to write a program which finds all the suspects.

Input

The input file contains several cases. Each test case begins with two integers n and m in a line, where n is the number of students, and m is the number of groups. You may assume that 0 < n <= 30000 and 0 <= m <= 500. Every student is numbered by a unique integer between 0 and n−1, and initially student 0 is recognized as a suspect in all the cases. This line is followed by m member lists of the groups, one line per group. Each line begins with an integer k by itself representing the number of members in the group. Following the number of members, there are k integers representing the students in this group. All the integers in a line are separated by at least one space. 
A case with n = 0 and m = 0 indicates the end of the input, and need not be processed.

Output

For each case, output the number of suspects in one line.

Sample Input

100 4
2 1 2
5 10 13 11 12 14
2 0 1
2 99 2
200 2
1 5
5 1 2 3 4 5
1 0
0 0

Sample Output

4
1
1

Source






题目类型:并查集

题目描述:现在有n个人,被分成若干组,一个人可以在多个组。现在有一种传染病,因为同组之间的成员交往比较频繁,所以某组只要一个人患病,那么认定该组所有人都患病。现在确定0号人已经患病。问你现在有多少人患病。

题目分析:比较裸的并查集。这题虽然是静态图,用搜索也可以。但是用并查集写起来更简单。

代码如下:

#include <iostream>
#include <stdio.h>
#define N 30001
using namespace std;

int f[N];
int rank[N];
int n;
int m;

void init(){
    for(int i = 0; i < n; i++){
        f[i] = i;
    }
    memset(rank,0,sizeof(rank));
}

int find(int x){
    if( x == f[x] ) {
        return x;
    } else {
        return f[x] = find(f[x]);
    }
}
void merge(int a,int b){
    int ra = find(a);
    int rb = find(b);
    if( ra != rb ){
        if( rank[ra] < rank[rb]){
            f[ra] = rb;
        } else {
            f[rb] = ra;
            if( rank[ra] == rank[rb]) {
                rank[ra]++;
            }
        }
    }
}

int main()
{
    while(scanf("%d%d",&n,&m), n || m){
        init();
        int k = 0;
        int first = 0;
        int temp = 0;
        for(int i = 0; i < m; i++){
            scanf("%d",&k);
            if( k > 0) {
                scanf("%d",&first);
                for(int j = 1; j <= k-1; j++){
                    scanf("%d",&temp);
                    merge(first,temp);
                }
            }
        }
        int target = find(0);
        int sum = 0;
        for(int i = 0; i < n ;i++){
            if(find(i) == target){
                sum++;
            }
        }
        printf("%d\n",sum);
    }
    return 0;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值