ZOJ 3710Friends

Friends

Time Limit:   2000ms
Memory Limit:   65536KB
This problem will be judged on   ZJU. Original ID:   3710
64-bit integer IO format:   %lld       Java class name:   Main
Type:  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •                    
  • Alice lives in the country where people like to make friends. The friendship is bidirectional and if any two person have no less than k friends in common, they will become friends in several days. Currently, there are totally n people in the country, and m friendship among them. Assume that any new friendship is made only when they have sufficient friends in common mentioned above, you are to tell how many new friendship are made after a sufficiently long time.

    Input

    There are multiple test cases.

    The first lien of the input contains an integer T (about 100) indicating the number of test cases. Then T cases follow. For each case, the first line contains three integers n, m, k (1 ≤ n ≤ 100, 0 ≤ m ≤ n×(n-1)/2, 0 ≤ k ≤ n, there will be no duplicated friendship) followed by m lines showing the current friendship. The ith friendship contains two integers ui, vi (0 ≤ ui, vi < nui ≠ vi) indicating there is friendship between person ui and vi.

    Note: The edges in test data are generated randomly.

    Output

    For each case, print one line containing the answer.

    Sample Input

    3
    4 4 2
    0 1
    0 2
    1 3
    2 3
    5 5 2
    0 1
    1 2
    2 3
    3 4
    4 0
    5 6 2
    0 1
    1 2
    2 3
    3 4
    4 0
    2 0

    Sample Output

    2
    0
    4
    现在很烦,对写题突然失去了兴趣,不是不想写,主要英文差,题目能让我看好久,
    而且现在的我还拒绝翻译,怎么办我很痛苦啊;
    快市赛了,队里没一个过4级的,我的英语在对里算是好的,到时候因为看不懂题写水题慢,翻车
    怎么给自己和老郭翻译,最重要我们2队刚不过女队,真心丢人;
    题意
    有n个人有要是俩个人要想成为朋友,要至少有k个共同认识的人;
    简单的map遍历,直接看代码;
    #include<iostream>
    #include<cstdio>
    #include<cmath>
    #include<cstring>
    #include<string>
    #include<algorithm>
    #include<stack>
    #include<queue>
    using namespace std;
    int map[200][200];
    int main()
    {
    	//std::ios::sync_with_stdio(false);
    	int t;
    	while (cin>>t)
    	{
    		while (t--)
    		{
    			memset(map, 0, sizeof(map));
    			int n, m, k, i, j;
    			scanf("%d%d%d", &n, &m, &k);
    			int x, y;
    			while (m--)
    			{
    				scanf("%d%d", &x, &y);
    				map[x][y] = map[y][x] = 1;
    			}
    			int count1 = 0, count2 = 0;
    			for (i = 0; i < n; i++)
    			{
    				for (j = 0; j < n; j++)
    				{
    					count1 = 0;
    					if (i != j&&map[i][j] == 0)
    					{
    						for (int p = 0; p < n; p++)
    						{
    							if (map[i][p] == map[j][p] && map[i][p] == 1)
    								count1++;
    						}
    						if (count1 >= k)
    						{
    							count2++;
    							map[i][j] = 1;
    							map[j][i] = 1;
    							i = 0;
    							break;
    						}
    					}
    				}
    			}
    			cout << count2 << endl;
    		}
    	}
    	return 0;
    }
    • 0
      点赞
    • 0
      收藏
      觉得还不错? 一键收藏
    • 0
      评论
    评论
    添加红包

    请填写红包祝福语或标题

    红包个数最小为10个

    红包金额最低5元

    当前余额3.43前往充值 >
    需支付:10.00
    成就一亿技术人!
    领取后你会自动成为博主和红包主的粉丝 规则
    hope_wisdom
    发出的红包
    实付
    使用余额支付
    点击重新获取
    扫码支付
    钱包余额 0

    抵扣说明:

    1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
    2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

    余额充值