HDU 1010 深搜+剪枝

补充剪枝知识
曼哈顿距离请点链接
manhattan距离
奇偶剪枝
奇偶剪枝ii
或者直接看这两个百度百科介绍
Tempter of the Bone

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 121013 Accepted Submission(s): 32671

Problem Description
The doggie found a bone in an ancient maze, which fascinated him a lot. However, when he picked it up, the maze began to shake, and the doggie could feel the ground sinking. He realized that the bone was a trap, and he tried desperately to get out of this maze.

The maze was a rectangle with sizes N by M. There was a door in the maze. At the beginning, the door was closed and it would open at the T-th second for a short period of time (less than 1 second). Therefore the doggie had to arrive at the door on exactly the T-th second. In every second, he could move one block to one of the upper, lower, left and right neighboring blocks. Once he entered a block, the ground of this block would start to sink and disappear in the next second. He could not stay at one block for more than one second, nor could he move into a visited block. Can the poor doggie survive? Please help him.

Input
The input consists of multiple test cases. The first line of each test case contains three integers N, M, and T (1 < N, M < 7; 0 < T < 50), which denote the sizes of the maze and the time at which the door will open, respectively. The next N lines give the maze layout, with each line containing M characters. A character is one of the following:

‘X’: a block of wall, which the doggie cannot enter;
‘S’: the start point of the doggie;
‘D’: the Door; or
‘.’: an empty block.

The input is terminated with three 0’s. This test case is not to be processed.

Output
For each test case, print in one line “YES” if the doggie can survive, or “NO” otherwise.

Sample Input
4 4 5
S.X.
..X.
..XD
….
3 4 5
S.X.
..X.
…D
0 0 0

Sample Output
NO
YES

看我的
屌丝代码

#include<iostream>
#include<cstdio>
#include<cmath>
#include<cstring>
#include<string>
#include<algorithm>
#include<stack>
#include<queue>
#include<cctype>
#include<functional>
using namespace std;
#define swap(a,b) {long long c=a;a=b;b=c;}
const int MAX = 999999;
const double Eps = 1e-12;
const double PI = acos(-1.0);
char map[20][20];
int stu[100][100];
int dir[4][2] = { {1,0},{-1,0},{0,1},{0,-1} }, flag;
int sx, ex, sy, ey,n, m, t;
int gcd(int x, int y)
{
    return x%y == 0 ? y : gcd(y, x%y);
}
void dfs(int x, int y, int count)
{
    if (x == ex && y == ey&& count == t)
    {
        flag = 1;
        return;
    }
    if (count >= t)
        return;
    if (map[x][y] != 'X')
    {
        for (int i = 0; i < 4; i++)
        {
            int tx = x + dir[i][0];
            int ty = y + dir[i][1];
            if (map[tx][ty] != 'X'&&tx >= 1 && tx <= n&&ty >= 1 && ty <= m && !stu[tx][ty])
            {
                stu[tx][ty] = 1;
                dfs(tx, ty, count + 1);
                stu[tx][ty] = 0;
                if (flag )
                    return;
            }

        }
    }

}
int main()
{
    while (cin >> n >> m >> t&&(n+m+t))
    {
        int i, j,cnt;
        for (i = 1; i <= n; i++)
        {
            getchar();
            for (j = 1; j <= m; j++)
            {
                cin >> map[i][j];
                if (map[i][j] == 'S')
                {
                    sx = i;
                    sy = j;
                }
                if (map[i][j] == 'D')
                {
                    ex = i;
                    ey = j;
                }   
            }

        }
    //  cout << sx << endl;
    //  cout << sy << endl;
    //  puts("******");
        if (abs(ex - sx) + abs(ey - sy) > t || (t - (abs(ex - sx) + abs(ey - sy))) % 2 == 1)
            puts("NO");
        else
        {
            flag = 0;
            cnt = 0;
            memset(stu, 0, sizeof(stu));
            stu[sx][sy] = 1;
            dfs(sx, sy, cnt);
    //      cout << flag << endl;
        //  puts(")))))))");
            printf(flag ? "YES\n" : "NO\n");
        }


    }
    return 0;
}
/*
4 4 5
S.X.
..X.
..XD
....
3 4 5
S.X.
..X.
...D
0 0 0
*/

评测机坑的一笔,知道今天我才在学长的指点提示下明白,评测机也是会爆炸的
只有下面这种getchar()的去空格方法才是对的;
像这种

//getchar();
        for (int i = 0; i < N; i++)
        {
            getchar();
            for (int j = 0; j < M; j++)
            {
                //cin >> map[i][j];
                scanf("%c", &map[i][j]);
                if (map[i][j] == 'S')
                    sx = i, sy = j;
                if (map[i][j] == 'D')
                    dx = i, dy = j;
            }
        //  getchar();
        }

就会wa
所以 以后还是不要骚操作,开标记数组兑;
不然坑;

#include<iostream>
#include<cstdio>
#include<cmath>
#include<cstring>
#include<string>
#include<algorithm>
#include<stack>
#include<queue>
#include<cctype>
#include<functional>
using namespace std;
#define swap(a,b) {long long c=a;a=b;b=c;}
const int MAX = 999999;
const double Eps = 1e-12;
const double PI = acos(-1.0);
int gcd(int x, int y)
{
    return x%y == 0 ? y : gcd(y, x%y);
}
int N, M, T;
char map[10][10];
int flag;
int sx, sy, dx, dy;
int dir[4][2] = { 1,0 ,-1,0 ,0,1 , 0,-1 };
void dfs(int x, int y, int t)
{
    if (x == dx&&y == dy && t == T)
    {
        flag = 1;
        return;
    }
    if (t + abs(x - dx) + abs(y - dy) > T || t >= T || (T - t - (abs(x - dx) + abs(y - dy))) % 2)
        return;
    //if (map[x][y] != 'X')
    {
        for (int i = 0; i < 4; i++)
        {
            int tx = x + dir[i][0];
            int ty = y + dir[i][1];
            if (map[tx][ty] != 'X'&&tx >= 0 && tx < N && ty >= 0 && ty < M)
            {
                map[x][y] = 'X';
                dfs(tx, ty, t + 1);
                map[x][y] = '.';
                if (flag)
                    return;
            }
        }
    }
}

int main()
{
    while (cin >> N >> M >> T && (N + M + T))
    {
        getchar();
        for (int i = 0; i < N; i++)
        {
        //  getchar();
            for (int j = 0; j < M; j++)
            {
                //cin >> map[i][j];
                scanf("%c", &map[i][j]);
                if (map[i][j] == 'S')
                    sx = i, sy = j;
                if (map[i][j] == 'D')
                    dx = i, dy = j;
            }
            getchar();
        }
        //getchar();
        //    for (int i = 0; i < N; i++)
        //{
        //        for (int j = 0; j < M; j++)
        //            cout << map[i][j];
        //        puts("");
        //    }
        //int ant = 0;
        if (abs(sx - dx) + abs(sy - dy) > T || (T - (abs(sx - dx) + abs(sy - dy))) % 2)
            puts("NO");
        else
        {
            flag = 0;
            map[sx][sy] = 'X';
            dfs(sx, sy, 0);
            printf(flag ? "YES\n" : "NO\n");
        }

    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值