VJ组队赛->Dancing Stars on Me(5533)

Problem Description
The sky was brushed clean by the wind and the stars were cold in a black sky. What a wonderful night. You observed that, sometimes the stars can form a regular polygon in the sky if we connect them properly. You want to record these moments by your smart camera. Of course, you cannot stay awake all night for capturing. So you decide to write a program running on the smart camera to check whether the stars can form a regular polygon and capture these moments automatically.
Formally, a regular polygon is a convex polygon whose angles are all equal and all its sides have the same length. The area of a regular polygon must be nonzero. We say the stars can form a regular polygon if they are exactly the vertices of some regular polygon. To simplify the problem, we project the sky to a two-dimensional plane here, and you just need to check whether the stars can form a regular polygon in this plane.

Input
The first line contains a integer T indicating the total number of test cases. Each test case begins with an integer n , denoting the number of stars in the sky. Following n lines, each contains 2 integers xi,yi , describe the coordinates of n stars.

1T300
3n100
10000xi,yi10000
All coordinates are distinct.

Output
For each test case, please output "`YES`" if the stars can form a regular polygon. Otherwise, output "`NO`" (both without quotes).

Sample Input
  
  
3 3 0 0 1 1 1 0 4 0 0 0 1 1 0 1 1 5 0 0 0 1 0 2 2 2 2 0

Sample Output
  
  
NO YES NO
题目大意:给你n个点,看看这几个点能不能构成一个正n边形
题意很明确,但当时没想到怎么做啊QAQ,其实思路很简单的QAQ,找出最小的一条边len就是边长,然后判断长度等于len的条数是不是n个,即为正n边形
#include <iostream>
#include <algorithm>
#include <cstdio>
#include <cmath>

using namespace std;

const int N = 101;

double x[N],y[N];
double distance(int i,int j)
{
	return sqrt((x[i]-x[j])*(x[i]-x[j]) + (y[i]-y[j])*(y[i]-y[j]));
}
int main()
{
	int t,n;
	cin >> t;
	while(t--)
	{
		cin >> n;
		int i,j;
		for(i = 0; i < n; i++)
			scanf("%lf%lf",&x[i],&y[i]);
		double len = 1e9;
		int num = 0;
		for(i = 1; i < n; i++)
	        len = min(len,distance(0,i));
		for(i = 0; i < n-1; i++)
		{
			for(j = i+1; j < n; j++)
				if(distance(i,j) == len)
					num ++;
		}
		if(num == n)
			cout << "YES\n";
		else
			cout << "NO\n";
	}
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值