HDU 1008 Elevator

Problem Description

The highest building in our city has only one elevator. A request list is made up with N positive numbers. The numbers denote at which floors the elevator will stop, in specified order. It costs 6 seconds to move the elevator up one floor, and 4 seconds to move down one floor. The elevator will stay for 5 seconds at each stop.

For a given request list, you are to compute the total time spent to fulfill the requests on the list. The elevator is on the 0th floor at the beginning and does not have to return to the ground floor when the requests are fulfilled.

Input

There are multiple test cases. Each case contains a positive integer N, followed by N positive numbers. All the numbers in the input are less than 100. A test case with N = 0 denotes the end of input. This test case is not to be processed.

Output

Print the total time on a single line for each test case.

Sample Input

1 2
3 2 3 1
0

Sample Output

17
41

题目大意:

先输入一个数字n表示操作次数,当n为0时结束。接下来输入要去的层数,每上一层需要6秒,下一层需要4秒,每开门一次需要5秒。所需开门次数为n-1。

c++:

#include <iostream>
using namespace std;
int main()
{
    int a[110];           //a数组用来存放要去的层数
    int b,c,d,e,f,g;      //b表示操作次数,g是所需时间
    while(cin>>b)
    {
        g=0;
        if(b==0)
            break;
        for(c=0;c<b;c++)
        {
            cin>>a[c];
        }
        d=0;
        g=g+a[0]*6;
        for(c=0;c<b-1;c++)
        {
            if(a[c+1]>a[c])
            {
                g=g+(a[c+1]-a[c])*6;
            }
            else
            {
                g=g+(a[c]-a[c+1])*4;
            }
        }
        g=g+5*b;
        cout<<g<<endl;
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值