HDU 2017 多校联赛2 1001 Is Derek lying?

Problem Description

Derek and Alfia are good friends.Derek is Chinese,and Alfia is Austrian.This summer holiday,they both participate in the summer camp of Borussia Dortmund.During the summer camp,there will be fan tests at intervals.The test consists of N choice questions and each question is followed by three choices marked “A” “B” and “C”.Each question has only one correct answer and each question is worth 1 point.It means that if your answer for this question is right,you can get 1 point.The total score of a person is the sum of marks for all questions.When the test is over,the computer will tell Derek the total score of him and Alfia.Then Alfia will ask Derek the total score of her and he will tell her: “My total score is X,your total score is Y.”But Derek is naughty,sometimes he may lie to her. Here give you the answer that Derek and Alfia made,you should judge whether Derek is lying.If there exists a set of standard answer satisfy the total score that Derek said,you can consider he is not lying,otherwise he is lying.

Input

The first line consists of an integer T,represents the number of test cases.

For each test case,there will be three lines.

The first line consists of three integers N,X,Y,the meaning is mentioned above.

The second line consists of N characters,each character is “A” “B” or “C”,which represents the answer of Derek for each question.

The third line consists of N characters,the same form as the second line,which represents the answer of Alfia for each question.

Data Range:1≤N≤80000,0≤X,Y≤N,∑Ti=1N≤300000

Output

For each test case,the output will be only a line.

Please print “Lying” if you can make sure that Derek is lying,otherwise please print “Not lying”.

Sample Input


3 1 3 
AAA 
ABC 
5 5 0 
ABCBC 
ACBCB

Sample Output

Not lying 
Lying

题目大意:

输入一个数字n,表示题目个数,接下来两个数字x,y表示两个人的分数,接下来两行输入这两个人分别的答案,每题的三个选项是由“A”B”和“C”。每题只有一个正确答案,每道题1分。这意味着,如果你对这个问题的回答是正确的,你可以得到1点。一个人总得分是所有问题的分数的总和。考试结束的时候,电脑会告诉德里克他和alfia总分。然后Alfia问德里克她的总成绩,他会告诉她:“我的总成绩是X,你的总分是Y.吗?”但是德里克很调皮,有时他可能会对她撒谎。这里给你答案,德里克和Alfia,你应该判断德里克是否在撒谎。如果存在一套标准答案满足总得分,德里克说,你可以认为他在撒谎,否则他在撒谎

c++

#include<cstdio>
#include<cstring>
#include<cmath>

using namespace std;
char s1[300010],s2[300010];
int main()
{
    int t;
    scanf("%d",&t);
    while(t--){
       int a,b,n;
       scanf("%d %d %d",&n,&a,&b);
       scanf("%s",s1);
       scanf("%s",s2);
       int c=0;
       for(int i=0;i<n;i++){
        if(s1[i]==s2[i]) c++;
       }
      if(a+b<=n+c&&abs(a-b)<=n-c){
        printf("Not lying\n");
      }
      else{
        printf("Lying\n");
      }
    }
    return 0;
}





  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值