【PAT】1006 Sign In and Sign Out (25分) (比较 模拟)

题目:

At the beginning of every day, the first person who signs in the computer room will unlock the door, and the last one who signs out will lock the door. Given the records of signing in's and out's, you are supposed to find the ones who have unlocked and locked the door on that day.

Input Specification:

Each input file contains one test case. Each case contains the records for one day. The case starts with a positive integer M, which is the total number of records, followed by M lines, each in the format:

ID_number Sign_in_time Sign_out_time

where times are given in the format HH:MM:SS, and ID_number is a string with no more than 15 characters.

Output Specification:

For each test case, output in one line the ID numbers of the persons who have unlocked and locked the door on that day. The two ID numbers must be separated by one space.

Note: It is guaranteed that the records are consistent. That is, the sign in time must be earlier than the sign out time for each person, and there are no two persons sign in or out at the same moment.

Sample Input:

3
CS301111 15:30:28 17:00:10
SC3021234 08:00:00 11:25:25
CS301133 21:45:00 21:58:40

Sample Output:

SC3021234 CS301133

题目大意:第一个登记(signs)进入机房的人要开门,最后一个登记进入机房的人要关门,登记表会记录他们的开门和关门时间。

输入 :N(登记人数) 随后N个信息,每个包括id,进入时间,离开时间;

输出:最早进入的人和最晚离开的人

解题思路:c++的string类型可以字典序排序,所以直接用string来比就行了 还免得进制转换了。

代码:

#include<iostream>
using namespace std;
struct node{
   string id,in,out;
};
int main(){
 node temp;
  string inid,outid;
  string min="24:59:59";
  string mout="00:00:00";
  int n;
  cin>>n;

  while(n--){
    cin>>temp.id>>temp.in>>temp.out;
    if(temp.in<min){
      min=temp.in;
      inid=temp.id;
    }
    if(temp.out>mout){
      mout=temp.out;
      outid=temp.id;
    }
  }
  cout<<inid<<" "<<outid<<endl;
  return 0;
}

也可以不用结构体,直接比,代码如下:

#include<iostream>
using namespace std;

int main(){
	string id,in,out;
  string inid,outid;
  string min="24:59:59";
  string mout="00:00:00";
  int n;
  cin>>n;

  while(n--){
    cin>>id>>in>>out;
    if(in<min){
      min=in;
      inid=id;
    }
    if(out>mout){
      mout=out;
      outid=id;
    }
  }
  cout<<inid<<" "<<outid<<endl;
  return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值