PAT甲级 1006 Sign In and Sign Out(25分)

题目

At the beginning of every day, the first person who signs in the computer room will unlock the door, and the last one who signs out will lock the door. Given the records of signing in’s and out’s, you are supposed to find the ones who have unlocked and locked the door on that day.

Input Specification:

Each input file contains one test case. Each case contains the records for one day. The case starts with a positive integer M, which is the total number of records, followed by M lines, each in the format:

ID_number Sign_in_time Sign_out_time

where times are given in the format HH:MM:SS, and ID_number is a string with no more than 15 characters.

Output Specification:

For each test case, output in one line the ID numbers of the persons who have unlocked and locked the door on that day. The two ID numbers must be separated by one space.

Note: It is guaranteed that the records are consistent. That is, the sign in time must be earlier than the sign out time for each person, and there are no two persons sign in or out at the same moment.

Sample Input:

3
CS301111 15:30:28 17:00:10
SC3021234 08:00:00 11:25:25
CS301133 21:45:00 21:58:40

Sample Output:

SC3021234 CS301133

题解

题目大意

每天第一个来的同志签到后要开锁,最后一个签退的同志要锁门。输入大家伙的编号和签到签退时间,输出开锁人和锁门人的编号。

非正规思路

首先看完题目,可以分析得出这是一道模拟题(也就是不涉及什么复杂的算法啥的,按部就班地用代码把题目过程表示出来就可以)。以下为非正规的三步走过程:
输入
① 整数M(表示接下来人员数)
② 人员编号 签到时间 签退时间
过程
每输入一行记录,对签到签退时间进行计算判断,更新unlockP和lockP
输出
① 开锁人编号 锁门人编号

挫挫的代码

#include<bits/stdc++.h> 
using namespace std;
int main(){
	int m;
	string personCode;
	int h1, m1, s1, h2, m2, s2;
	int minn = INT_MAX, maxn = INT_MIN;
	int beginT, endT;
	string unlockP, lockP;
	
	while(scanf("%d", &m)!=EOF){
		for(int i=0;i<m;i++){
			cin >> personCode;
			scanf("%d:%d:%d %d:%d:%d", &h1, &m1, &s1, &h2, &m2, &s2);
			beginT = s1 + m1*60 + h1*60*60;
			endT = s2 + m2*60 + h2*60*60;
			if(beginT < minn){
				minn = beginT;
				unlockP = personCode;
			}
			if(endT > maxn){
				maxn = endT;
				lockP = personCode;
			}
		}
		cout << unlockP << " " << lockP;
	}
	
	return 0;
} 

絮絮叨叨

就是冲!就是肝!

参考博客

https://blog.csdn.net/a617976080/article/details/89676670

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值