HD OJ 1002Problem 大数相加

A + B Problem II

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 139440    Accepted Submission(s): 26450


Problem Description
I have a very simple problem for you. Given two integers A and B, your job is to calculate the Sum of A + B.
 

Input
The first line of the input contains an integer T(1<=T<=20) which means the number of test cases. Then T lines follow, each line consists of two positive integers, A and B. Notice that the integers are very large, that means you should not process them by using 32-bit integer. You may assume the length of each integer will not exceed 1000.
 

Output
For each test case, you should output two lines. The first line is "Case #:", # means the number of the test case. The second line is the an equation "A + B = Sum", Sum means the result of A + B. Note there are some spaces int the equation. Output a blank line between two test cases.
 

Sample Input
  
  
2 1 2 112233445566778899 998877665544332211
 

Sample Output
  
  
Case 1: 1 + 2 = 3 Case 2: 112233445566778899 + 998877665544332211 = 1111111111111111110
 
分析:
该题为大数相加,将数字放在字串中进行运算即可。
代码:
#include <iostream>
using namespace std;
int main(int argc, const char * argv[])
{
    char a[1001],b[1001],c[2000];
    int x,y,m,z,n;
    cin>>n;getchar();
    for(int j=0;j<n;j++){z=0;cout<<"Case "<<j+1<<":"<<endl;
    for(x=1,a[0]='0';(a[x]=getchar())>='0'&&a[x]<='9';x++){cout<<a[x];};
    cout<<" + ";x--;
    for(y=1,b[0]='0';(b[y]=getchar())>='0'&&b[y]<='9';y++){cout<<b[y];};
    cout<<" = ";y--;
    for(m=0;x>0||y>0;m++)
    {c[m]=(z=(a[x]-'0'+z+b[y]-'0'))%10+'0';z/=10;
     x>0?x--:x=0;y>0?y--:y=0;
    }if(z!=0){c[m]=z+'0';m++;}
    for(m-=1;m>=0;m--)
        cout<<c[m];
    if(j!=n-1)cout<<endl<<endl;
    }
    return 0;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值