1160FatMouse's Speed

这道题真是让我煞费了苦心。为了AC午饭都没吃,打算把博客写完吃饭去。

从早上开始做这道题,利用动归思想。

起初,以为可以很容易AC结果写完一提交,越界!扩大数组长度,还是越界,无奈debug,发现在for循环中将j写成i。改完再提交,WA!再次debug,居然是输出函数写的不对,当时一激动竟然忘了p是数组下标,直接输出p了

通过这个题我要反思一下我自己,以后一定要严格要求自己,事无巨细,一定要认真对待,绝不能马马虎虎!眼高手低!

 

题目:

FatMouse's Speed

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 6060    Accepted Submission(s): 2629
Special Judge


Problem Description
FatMouse believes that the fatter a mouse is, the faster it runs. To disprove this, you want to take the data on a collection of mice and put as large a subset of this data as possible into a sequence so that the weights are increasing, but the speeds are decreasing.
 

Input

Input contains data for a bunch of mice, one mouse per line, terminated by end of file.

The data for a particular mouse will consist of a pair of integers: the first representing its size in grams and the second representing its speed in centimeters per second. Both integers are between 1 and 10000. The data in each test case will contain information for at most 1000 mice.

Two mice may have the same weight, the same speed, or even the same weight and speed.
 
Output
Your program should output a sequence of lines of data; the first line should contain a number n; the remaining n lines should each contain a single positive integer (each one representing a mouse). If these n integers are m[1], m[2],..., m[n] then it must be the case that

W[m[1]] < W[m[2]] < ... < W[m[n]]

and

S[m[1]] > S[m[2]] > ... > S[m[n]]

In order for the answer to be correct, n should be as large as possible.
All inequalities are strict: weights must be strictly increasing, and speeds must be strictly decreasing. There may be many correct outputs for a given input, your program only needs to find one.
 
Sample Input
  
  
6008 1300 6000 2100 500 2000 1000 4000 1100 3000 6000 2000 8000 1400 6000 1200 2000 1900
 
Sample Output
  
  
4 4 5 9 7
 
目分析:
首先定义数据结构
struct mouse{
    int id;          //标号
    int weight;     
    int speed;
    int pre;         //前驱
};
利用qsort函数先对weight进行升序排序,weight相等时再对speed进行降序排序
 
m[i] 用来存储排序好的数组中,下标为i时满足条件的最优值
动态方程
m[i]= max{ m[j] } +1   (i>j)
 
 
代码:
#include<iostream>
#include<algorithm>
#include<String>
using namespace std;
struct mouse{
    int id;          //标号
    int weight;      
    int speed;
    int pre;         //前驱
};
mouse ms[1010];  //用来存储老鼠的信息
int m[1010];     //排序号后,在下标i处的最优解
int cmp(const void *a,const void *b)
{
    struct mouse *c=(mouse *)a;
    struct mouse *d=(mouse *)b;
    if(c->weight!=d->weight)
        return (c->weight - d->weight);
    else
        return(d->speed - c->speed);
}

void qout(int p)
{
	if(m[p]==1)
		cout<<ms[p].id<<endl;
	else
	{
		int q=ms[p].pre ;
		qout(q);
		cout<<ms[p].id<<endl;
	}
}

   //用来存储下标为i时的最优值
int main()
{
    int n=0,i=1;
    while(cin>>ms[n].weight>>ms[n].speed)
    {
        ms[n].id=i;
        m[n]=1;
        n++;
        i++;
	//	if(n>=9)
	//		break;
    
    }
    //n为数据的个数
    qsort(ms,n,sizeof(ms[0]),cmp);
    ms[0].pre=0;
    for(i=1;i<n;i++)
    {
        ms[i].pre=i;
        for(int j=0;j<i;j++)
        {
            if((ms[i].weight>ms[j].weight)&&(ms[i].speed<ms[j].speed))
            {
                if(m[i]<m[j]+1)
                  {
                      m[i]=m[j]+1;
                      ms[i].pre=j;
                  }

            }

        }
    }
    int max=-1;
    int p=0;
    for(int k=0;k<n;k++)
    {
        if(m[k]>max)
        {
            max=m[k];
            p=k;
        }
    }
    cout<<max<<endl;
    qout(p);

    return 0;
}

 
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值