数据结构实验之求二叉树后序遍历和层次遍历

题目描述

 已知一棵二叉树的前序遍历和中序遍历,求二叉树的后序遍历。

输入

 输入数据有多组,第一行是一个整数t (t<1000),代表有t组测试数据。每组包括两个长度小于50 的字符串,第一个字符串表示二叉树的先序遍历序列,第二个字符串表示二叉树的中序遍历序列。

输出

每组第一行输出二叉树的后序遍历序列,第二行输出二叉树的层次遍历序列

示例输入

2
abdegcf
dbgeafc
xnliu
lnixu

示例输出

dgebfca
abcdefg
linux
xnuli


#include <stdio.h>
#include <string.h>
#include <stdlib.h>
struct node
{
    char data;
    struct node *l,*r;
};

struct node *creat(int len,char *s1,char *s2)
{
    struct node *root;
    char *p;
    if(len==0)
        return NULL;
    root=(struct node *)malloc(sizeof(struct node));
    root->data=s1[0]; //前序第一个为结点
    for(p=s2; p!='\0'; p++)  //在中序找结点,找到跳出循环
    {
        if(*p==s1[0])
            break;
    }
    int t=p-s2; //左子树长度
    root->l=creat(t,s1+1,s2); //左子树长度,在s1左树开始地址,在s2开始地址
    root->r=creat(len-t-1,s1+t+1,p+1);//右子树长度,后面同上
    return root;
};
void houxu(struct node *root)
{
    if(root)  //如果结点不为空
    {
        houxu(root->l);
        houxu(root->r);
        printf("%c",root->data);
    }
}
void cengci(struct node *root)
{
    int count=0;
    int rr=1;
    struct node *q[100];
    q[0]=root;
    while(count<rr)//每一个q[count]都是子树树根
    {
        if(q[count])//这是为二叉树,且最多有两个子树
        {
            printf("%c",q[count]->data);
            q[rr++]=q[count]->l;  //rr++是下一级的树根
            q[rr++]=q[count]->r;
        }
        count++;
    }
}
int main()
{
    int t,len;
    char s1[100],s2[100],n;
    struct node *root;
    root=(struct node *)malloc(sizeof(struct node));
    scanf("%d",&t);
    while(t--)
    {
        scanf("%s %s",s1,s2);
        len=strlen(s1);
        root=creat(len,s1,s2);
        houxu(root);
        printf("\n");
        cengci(root);
        printf("\n");
    }
    return 0;
}



评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值