SDUT OJ 数据结构实验之二叉树七:叶子问题

数据结构实验之二叉树七:叶子问题 

Time Limit: 1000MS Memory limit: 65536K 

题目描述

已知一个按先序输入的字符序列,如abd,,eg,,,cf,,,(其中,表示空结点)。请建立该二叉树并按从上到下从左到右的顺序输出该二叉树的所有叶子结点。

输入

  输入数据有多行,每一行是一个长度小于 50 个字符的字符串。

输出

  按从上到下从左到右的顺序输出二叉树的叶子结点。

示例输入

abd,,eg,,,cf,,,
xnl,,i,,u,,

示例输出

dfg
uli


#include <iostream>
#include <cstdio>
#include <queue>
#include <cstdlib>
using namespace std;
struct node
{
    char data;
    struct node *lchild,*rchild;
};
struct node *root;
char st[51];
int cnt;

struct node *BuidTree()
{
    struct node *root;
    if(st[cnt++] == ',')
        root = NULL;
    else
    {
        root = (struct node *)malloc(sizeof(struct node));
        root->data = st[cnt - 1];
        root->lchild = BuidTree();   //建左子树
        root->rchild = BuidTree();   //建右子树
    }
    return root;
}

void LeafIssue(struct node *root)
{
    queue<node *>s;
    s.push(root);
    
    while(!s.empty())
    {
        root = s.front();  // 访问队首元素,
        s.pop();           // 删除队首
        if(root)
        {
            if((root->rchild==NULL) && (root->lchild==NULL))
            {
                printf("%c",root->data);      // 如果是叶子结点则输出
            }
            s.push(root->lchild);       //左右子树一次入队
            s.push(root->rchild);
        }
    }
}

int main()
{
    while(~scanf("%s",st))
    {
        cnt = 0;
        root = BuidTree();
        LeafIssue(root);
        cout<<endl;
    }
    return 0;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值