[floyd]POJ 1125 Stockbroker Grapevine

传送门:Stockbroker Grapevine

Stockbroker Grapevine
Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 24775 Accepted: 13653

Description

Stockbrokers are known to overreact to rumours. You have been contracted to develop a method of spreading disinformation amongst the stockbrokers to give your employer the tactical edge in the stock market. For maximum effect, you have to spread the rumours in the fastest possible way. 

Unfortunately for you, stockbrokers only trust information coming from their "Trusted sources" This means you have to take into account the structure of their contacts when starting a rumour. It takes a certain amount of time for a specific stockbroker to pass the rumour on to each of his colleagues. Your task will be to write a program that tells you which stockbroker to choose as your starting point for the rumour, as well as the time it will take for the rumour to spread throughout the stockbroker community. This duration is measured as the time needed for the last person to receive the information.

Input

Your program will input data for different sets of stockbrokers. Each set starts with a line with the number of stockbrokers. Following this is a line for each stockbroker which contains the number of people who they have contact with, who these people are, and the time taken for them to pass the message to each person. The format of each stockbroker line is as follows: The line starts with the number of contacts (n), followed by n pairs of integers, one pair for each contact. Each pair lists first a number referring to the contact (e.g. a '1' means person number one in the set), followed by the time in minutes taken to pass a message to that person. There are no special punctuation symbols or spacing rules. 

Each person is numbered 1 through to the number of stockbrokers. The time taken to pass the message on will be between 1 and 10 minutes (inclusive), and the number of contacts will range between 0 and one less than the number of stockbrokers. The number of stockbrokers will range from 1 to 100. The input is terminated by a set of stockbrokers containing 0 (zero) people. 

Output

For each set of data, your program must output a single line containing the person who results in the fastest message transmission, and how long before the last person will receive any given message after you give it to this person, measured in integer minutes. 
It is possible that your program will receive a network of connections that excludes some persons, i.e. some people may be unreachable. If your program detects such a broken network, simply output the message "disjoint". Note that the time taken to pass the message from person A to person B is not necessarily the same as the time taken to pass it from B to A, if such transmission is possible at all.

Sample Input

3
2 2 4 3 5
2 1 2 3 6
2 1 2 2 2
5
3 4 4 2 8 5 3
1 5 8
4 1 6 4 10 2 7 5 2
0
2 2 5 1 5
0

Sample Output

3 2
3 10

Source


解题报告:

此题题意难理解。但是理解了就是一个floyd的题,此为有向图

题意:

首先,题目可能有多组测试数据,每个测试数据的第一行为经纪人数量N(当N=0时,
输入数据结束),然后接下来N行描述第i(1<=i<=N)个经纪人与其他经纪人的关系
(教你如何画图)。每行开头数字M为该行对应的经纪人有多少个经纪人朋友(该节点
的出度,可以为0),然后紧接着M对整数,每对整数表示成a,b,则表明该经纪人向第a
个经纪人传递信息需要b单位时间(即第i号结点到第a号结点的孤长为b),整张图为
有向图,即弧Vij 可能不等于弧Vji(数据很明显,这里是废话)。当构图完毕后,求
当从该图中某点出发,将“消息”传播到整个经纪人网络的最小时间,输出这个经纪
人号和最小时间。最小时间的判定方式为——从这个经纪人(结点)出发,整个经纪
人网络中最后一个人接到消息的时间。如果有一个或一个以上经纪人无论如何无法收
到消息,输出“disjoint”


以第一样例为例:
3
2 2 4 3 5
2 1 2 3 6
2 1 2 2 2

总共3个经纪人,一号经纪人可向2个人传递信息,向2号传递所需时间为4分钟,向3号
传递需5分钟。二号经纪人可向2个人传递信息,向1号需2分钟,向3号需6分钟。三号
经纪人可向2人传递信息,向1号需2分钟,向2号需2分钟。(以上阿拉伯数字即为对
应数据)

将图画出,很容易得出,从3号出发,网络中最后一个得到消息的,需2分钟(可以同时向多人传递,有点不合情理)。所以输出为 3 2。


代码如下:

#include<iostream>
#include<cstring>
#include<cstdio>
#include<algorithm>
#define INF 0x7fffffff
using namespace std;
int n,weight[110][110];
struct edge{
    int id,len;
}e[110];
bool cmp(const edge &a,const edge &b){
    return a.len<b.len;
}
void floyd(){
    for(int t=1;t<=n;t++)
        for(int i=1;i<=n;i++)
            for(int j=1;j<=n;j++)
                if(weight[i][t]!=INF&&weight[t][j]!=INF)
                    weight[i][j]=min(weight[i][j],weight[i][t]+weight[t][j]);
}
void fun(){
    for(int i=1;i<=n;i++){
        int maxn=0;
        for(int j=1;j<=n;j++)
            if(maxn<weight[i][j])
                maxn=weight[i][j];
        e[i].id=i;e[i].len=maxn;
    }
}
int main(){
    while(scanf("%d",&n)==1&&n){
        for(int i=1;i<=n;i++){
            for(int j=1;j<=n;j++)
                weight[i][j]=INF;
            weight[i][i]=0;
        }
        int num,ed,value;
        for(int i=1;i<=n;i++){
            scanf("%d",&num);
            while(num--){
                scanf("%d%d",&ed,&value);
                weight[i][ed]=value;
            }
        }
        floyd();
        fun();
        sort(e+1,e+n+1,cmp);
        if(e[1].len==INF)
            printf("disjoint\n");
        else
            printf("%d %d\n",e[1].id,e[1].len);
    }
    return 0;
}


1) { JOptionPane.showMessageDialog(this, "请选择要删除的图书!", "提示", JOptionPane.WARNING_MESSAGE); } else { 这是一道经典的最短路问题,可以使用Dijkstra算法或者Floyd算法来解决。 D String bookId = bookInfoTable.getValueAt(selectedRow, 0).toString(); int option = JOptionPane.showConfirmDialog(this, "确定要删除编号为 " + bookId + " 的图书吗?", "提示", JOptionPane.YES_NO_OPTION); if (optionijkstra算法的基本思想是从起点开始,依次遍历所有节点,每次选择距离起点最 == JOptionPane.YES_OPTION) { deleteBookInfo(bookId); loadBookInfo(); } } } else if (e.getSource() == backButton) { new MainFrame(); setVisible(false); } } private void loadBookInfo() { 近的节点进行松弛操作,直到到达终点或者所有节点都被遍历完。 Floyd算法则 tableModel.setRowCount(0); Connection conn = null; Statement stmt = null; ResultSet rs = null; try { 是通过动态规划求解所有节点之间的最短路径。具体来说,利用一个二维数组存 conn = DriverManager.getConnection("jdbc:mysql://localhost:3306/book_management?useSSL=false&serverTimezone=UTC", "root", "root"); stmt = conn.createStatement(); rs = stmt.executeQuery("SELECT * FROM book_info"); while (rs.next())储任意两个节点之间的最短距离,然后依次考虑增加中间节点,更新所有节点 { Object[] rowData = new Object[6]; rowData[0] = rs.getInt("book_id"); rowData[1]之间的距离,直到所有节点都被考虑过。 无论使用哪种算法,都需要先构建 = rs.getString("book_name"); rowData[2] = rs.getString("author"); rowData[3] = rs.getString("publisher"); rowData[4] = rs.getDouble("price"); rowData[5] = rs.getInt("quantity"); tableModel.addRow(row出图的邻接矩阵或邻接表,然后根据算法的要求进行处理即可。
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值