HDU ACM 1007 Quoit Design

原题描述

Problem Description

Have you ever played quoit in a playground? Quoit is a game in which flat rings are pitched at some toys, with all the toys encircled awarded.
In the field of Cyberground, the position of each toy is fixed, and the ring is carefully designed so it can only encircle one toy at a time. On the other hand, to make the game look more attractive, the ring is designed to have the largest radius. Given a configuration of the field, you are supposed to find the radius of such a ring.

Assume that all the toys are points on a plane. A point is encircled by the ring if the distance between the point and the center of the ring is strictly less than the radius of the ring. If two toys are placed at the same point, the radius of the ring is considered to be 0.

Input

The input consists of several test cases. For each case, the first line contains an integer N (2 <= N <= 100,000), the total number of toys in the field. Then N lines follow, each contains a pair of (x, y) which are the coordinates of a toy. The input is terminated by N = 0.

Output

For each test case, print in one line the radius of the ring required by the Cyberground manager, accurate up to 2 decimal places.

Sample Input

2
0 0
1 1
2
1 1
1 1
3
-1.5 0
0 0
0 1.5
0

Sample Output

0.71
0.00
0.75

解题思路

题意为求最小距离点对距离的二分之一。
如果全部枚举会超时,使用分治法。
先将所有点按x轴从小到大排序,然后二分法分别求左边半部分和右边半部分的最小点对距离。
然后将左右的点进行枚举对比,看看是否有跨过中线的点对距离比左右的小。
最后求得一个最小值即为答案。

参考代码

#include <iostream>
#include <algorithm>
#include <limits>
using namespace std;

double ans;
struct point
{
    double x, y;
}p[100002];
bool cmp(point p1,point p2)     // 比较函数
{
    if (p1.x < p2.x)
        return true;
    else if (p1.x == p2.x && p1.y < p2.y)
        return true;
    return false;
}
double power(double x)          // 平方函数
{
    return x*x;
}
double min(double a, double b) { return a < b ? a : b; }
double dis(point p1,point p2)   // 求两点间距离
{
    return power(p1.x - p2.x) + power(p1.y - p2.y);
}
void getMindistance(int l,int r)        // 求两下标间的最小间距
{
    if(l+5>=r)                          // 当只有5个以下点时采用枚举法
    {
        for (int i = l; i <= r;i++)
        {
            for (int j = i + 1; j <= r;j++)
            {
                ans = min(ans, dis(p[i], p[j]));
            }
        }
        return;
    }
    int mid = (l + r) / 2;
    // 分别求左右两边的最小间距
    getMindistance(l, mid);
    getMindistance(mid + 1, r);
    // 将中线两边的点进行比较,看看是否有比求得最小间距小的
    for (int i = l; i <= mid;i++)
    {
        for (int j = mid + 1; j <= r; j++)
        {
            double d = dis(p[i], p[j]);
            if (d >= ans)
                break;
            ans = d;
        }
    }
    return;
}

int main()
{
    int n, i;

    while(scanf("%d",&n),n!=0)
    {
        for (i = 0; i < n; i++)
            scanf("%lf%lf", &p[i].x, &p[i].y);
        sort(p, p + n, cmp);
        ans = FLT_MAX;
        getMindistance(0, n - 1);
        ans = sqrt(ans);
        printf("%.2lf\n", ans / 2);
    }
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 1
    评论
评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值