HDU ACM 1789 Doing Homework again

原题描述

Problem Description

Ignatius has just come back school from the 30th ACM/ICPC. Now he has a lot of homework to do. Every teacher gives him a deadline of handing in the homework. If Ignatius hands in the homework after the deadline, the teacher will reduce his score of the final test. And now we assume that doing everyone homework always takes one day. So Ignatius wants you to help him to arrange the order of doing homework to minimize the reduced score.

Input

The input contains several test cases. The first line of the input is a single integer T that is the number of test cases. T test cases follow.
Each test case start with a positive integer N(1<=N<=1000) which indicate the number of homework.. Then 2 lines follow. The first line contains N integers that indicate the deadlines of the subjects, and the next line contains N integers that indicate the reduced scores.

Output

For each test case, you should output the smallest total reduced score, one line per test case.

Sample Input

3
3
3 3 3
10 5 1
3
1 3 1
6 2 3
7
1 4 6 4 2 4 3
3 2 1 7 6 5 4

Sample Output

0
3
5

解题思路

将所有作业按照扣分数从大到小排序,先做扣分多的。
开一个数组记录当天是否被使用,然后枚举所有作业。
从一个作业的deadline向前枚举日期,如果发现空日期则做作业并占用日期,如果前面所有日期都满了则扣分。
累计扣分并输出。

参考代码

#include <iostream>
#include <algorithm>
using namespace std;

struct work             // 作业结构
{
    int deadline;
    int score;
    bool operator< (const work & w)const    // 重载<,作为比较函数
    {
        // 扣分越高越靠前
        return (score > w.score);
    }
}W[1001];
int taken[1001];                        // 当天是否被使用

int main()
{
    int t, n, i, j, ans;
    cin >> t;
    while(t--)
    {
        memset(taken, 0, sizeof(taken));// 0表示没有使用,1表示使用
        ans = 0;
        cin >> n;
        for (int i = 0; i < n;i++)
        {
            cin >> W[i].deadline;
        }
        for (int i = 0; i < n;i++)
        {
            cin >> W[i].score;
        }
        sort(W, W + n);                 // 使用重载的<符号排序

        for (i = 0; i < n;i++)      // 枚举每一个作业
        {
            for (j = W[i].deadline; j > 0;j--)      // 这个作业的deadline向前枚举日期,直到找到空的日子做作业
            {
                if(!taken[j])
                {
                    taken[j] = 1;
                    break;
                }
            }
            if (j == 0)                 // 如果没有找到空日子,那么扣分
                ans += W[i].score;
        }
        cout << ans << endl;
    }
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 2
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论 2
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值