SDUT1028Catch That Cow

Catch That Cow

Time Limit: 2000MS Memory limit: 65536K

题目描述

Farmer John has been informed of the location of a fugitive cow and wants to catch her immediately. He starts at a point N (0 ≤ N ≤ 100,000) on a number line and the cow is at a point K (0 ≤ K ≤ 100,000) on the same number line. Farmer John has two modes of transportation: walking and teleporting. * Walking: FJ can move from any point X to the points X - 1 or X + 1 in a single minute * Teleporting: FJ can move from any point X to the point 2 × X in a single minute. If the cow, unaware of its pursuit, does not move at all, how long does it take for Farmer John to retrieve it?

输入

Line 1: Two space-separated integers: N and K

输出

Line 1: The least amount of time, in minutes, it takes for Farmer John to catch the fugitive cow.

示例输入

5 17

示例输出

4

提示

过程上图

示例程序

#include <stdio.h>
#include <string.h>
#include <stdlib.h>
#include <queue>
#define Inf 100000
using namespace std;
struct node
{
    int data;
    int step;
};
int vis[100000];

int DFS(int n,int k)
{
    queue<node>p;
    node now,next;
    now.data=n;
    now.step=0;
    vis[now.data]=1;
    p.push(now);
    while(!p.empty())
    {
        now=p.front();
        p.pop();
        next=now;
        for(int i=0; i<3; i++)
        {
            if(i==0)
                next.data=now.data-1;
            else if(i==2)
                next.data=now.data+1;
            else
                next.data=now.data*2;
            next.step=now.step+1;
            if(next.data==k)
                return next.step;
            if(next.data>=0&&next.data<=Inf&&!vis[next.data])
            {
                vis[next.data]=1;
                p.push(next);
            }
        }
    }
    return 0;
}
int main()
{
    int n,k;
    while(~scanf("%d%d",&n,&k))
    {
        memset(vis,0,sizeof(vis));
        if(n<k)
            printf("%d\n",DFS(n,k));
        else if(n==k)
            printf("0\n");
        else
            printf("%d\n",n-k);
    }
    return 0;
}

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值