Semi-prime H-numbers
Time Limit: 1000MS | Memory Limit: 65536K | |
Total Submissions: 9138 | Accepted: 4045 |
Description
This problem is based on an exercise of David Hilbert, who pedagogically suggested that one study the theory of4n+1 numbers. Here, we do only a bit of that.
An H-number is a positive number which is one more than a multiple of four: 1, 5, 9, 13, 17, 21,... are theH-numbers. For this problem we pretend that these are the only numbers. TheH-numbers are closed under multiplication.
As with regular integers, we partition the H-numbers into units,H-primes, and H-composites. 1 is the only unit. AnH-number h is H-prime if it is not the unit, and is the product of twoH-numbers in only one way: 1 × h. The rest of the numbers areH-composite.
For examples, the first few H-composites are: 5 × 5 = 25, 5 × 9 = 45, 5 × 13 = 65, 9 × 9 = 81, 5 × 17 = 85.
Your task is to count the number of H-semi-primes. An H-semi-prime is an H-number which is the product of exactly twoH-primes. The two H-primes may be equal or different. In the example above, all five numbers areH-semi-primes. 125 = 5 × 5 × 5 is not an H-semi-prime, because it's the product of threeH-primes.
Input
Each line of input contains an H-number ≤ 1,000,001. The last line of input contains 0 and this line should not be processed.
Output
For each inputted H-number h, print a line stating h and the number of H-semi-primes between 1 and h inclusive, separated by one space in the format shown in the sample.
Sample Input
21 85 789 0
Sample Output
21 0 85 5 789 62
Source
题意:
一个H-number是所有的模四余一的数。
如果一个H-number是H-primes当且仅当它的因数只有1和它本身(除1外)。
一个H-number是H-semi-prime当且仅当它只由两个H-primes的乘积表示。
H-number剩下其他的数均为H-composite。
给你一个数h,问1到h有多少个H-semi-prime数。
题解:打表,线性筛
#include <iostream>
#include <stdio.h>
#include <string.h>
#include <math.h>
using namespace std;
int a[1000001];
int b[1000001];
void init()
{
int i, j;
for(i = 5; i <= 1000001; i += 4)
{
for(j = 5; j <= 1000001; j += 4)
{
if(i*j>1000001)
break;
if(a[i]==0&&a[j]==0)
{
a[i*j] = 1;
}
else
{
a[i*j] = -1;
}
}
}
int s=0;
for(i = 1; i < 1000001; i++)
{
if(a[i] == 1)
s++;
b[i] = s;
}
}
int main()
{
int n;
memset(a, 0, sizeof(a));
init();
while(~scanf("%d", &n) && n!=0)
{
printf("%d %d\n", n, b[n]);
}
return 0;
}