poj_1458 Common Subsequence

Description

A subsequence of a given sequence is the given sequence with some elements (possible none) left out. Given a sequence X = < x1, x2, ..., xm > another sequence Z = < z1, z2, ..., zk > is a subsequence of X if there exists a strictly increasing sequence < i1, i2, ..., ik > of indices of X such that for all j = 1,2,...,k, x ij = zj. For example, Z = < a, b, f, c > is a subsequence of X = < a, b, c, f, b, c > with index sequence < 1, 2, 4, 6 >. Given two sequences X and Y the problem is to find the length of the maximum-length common subsequence of X and Y.

Input

The program input is from the std input. Each data set in the input contains two strings representing the given sequences. The sequences are separated by any number of white spaces. The input data are correct.

Output

For each set of data the program prints on the standard output the length of the maximum-length common subsequence from the beginning of a separate line.

Sample Input

abcfbc         abfcab
programming    contest 
abcd           mnp

Sample Output

4
2
0

这道题的大意就是求两字符串之间的最大公共序列长度~注意~公共序列不是公共子串~中间不一定是连续的~

用到的就是动态规划~

有一点比较诡异的是~这题貌似木有规定字符串长度~

开始我的MAX定的是2000~结果Memory Limit Exceeded了~

后来定为200~结果数组又越界了~

最后定为1000~才AC了~囧……

#include"cstdio"
#include"string.h"
#define MAX 1000
int main()
{
	char s1[MAX];
	char s2[MAX];
	int len1,len2;
	int a[MAX+1][MAX+1];
	int i,j;
	freopen("input.txt","r",stdin);
	while(scanf("%s%s\n",s1,s2)!=EOF)
	{
		len1=strlen(s1);
		len2=strlen(s2);
		memset(a,0,sizeof(a));//初始化数组~
		for(i=1;i<=len1;i++)//开始动态规划~
			for(j=1;j<=len2;j++)
			{
				if(s1[i-1]==s2[j-1])
					a[i][j]=a[i-1][j-1]+1;
				else
					a[i][j]=(a[i-1][j]>a[i][j-1])?a[i-1][j]:a[i][j-1];
			}
		
		printf("%d\n",a[len1][len2]);	
	}
	
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值