POJ 2356 Find a multiple(抽屉原理)

Find a multiple
Time Limit: 1000MS
Memory Limit: 65536K
Total Submissions: 8078
Accepted: 3523
Special Judge

Description

The input contains N natural (i.e. positive integer) numbers ( N <= 10000 ). Each of that numbers is not greater than 15000. This numbers are not necessarily different (so it may happen that two or more of them will be equal). Your task is to choose a few of given numbers ( 1 <= few <= N ) so that the sum of chosen numbers is multiple for N (i.e. N * k = (sum of chosen numbers) for some natural number k).

Input

The first line of the input contains the single number N. Each of next N lines contains one number from the given set.

Output

In case your program decides that the target set of numbers can not be found it should print to the output the single number 0. Otherwise it should print the number of the chosen numbers in the first line followed by the chosen numbers themselves (on a separate line each) in arbitrary order. 

If there are more than one set of numbers with required properties you should print to the output only one (preferably your favorite) of them.

Sample Input

5
1
2
3
4
1

Sample Output

2
2
3

Source

题目大意:
给你N个数,其中的M个数可不可以是N的倍数
解题思路:
1、如果有0,那么0就是N的倍数
2、sum[ i ]=a[ 1 ]+a[ 2 ]+...a[ i ];
如果sum[ i ]%n==0,那么输出前 i 个数
3、如果sum[ j ] - sum[ j ]是 n  的倍数,那么输出 i + 1 到 j 的数;
其中 i , j 是肯定存在的,由抽屉原理可知
AC代码
#include<iostream>
#include<cstdio>
using namespace std;
int sum[10005],a[10005];
int main(){
	int n;
	scanf("%d",&n);
	int flag=0;
	int count=0;
	for(int i=1;i<=n;i++){
		scanf("%d",&a[i]);
		if(a[i]==0)flag=1;
		sum[i]=sum[i-1]+a[i];
		if(sum[i]%n==0){
			count=i;
		}
	}
	if(flag){
		printf("1\n0\n");
		return 0;
	}
	if(count!=0){
		printf("%d\n",count);
		for(int i=1;i<=count;i++){
			printf("%d\n",a[i]);
		}
		return 0;
	}
	for(int i=1;i<=n;i++){
		for(int j=i+1;j<=n;j++){
			if((sum[j]-sum[i])%n==0){
				printf("%d\n",j-i);
				for(int k=i+1;k<=j;k++){
					printf("%d\n",a[k]);
				}
				return 0;
			}
		}
	}
}


  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值