sort(HDU-3293)

Problem Description
As is known to all, long long ago sailormoon once was an association of fighters. Till now, sailormoon is also an association of girls. Owe to some unknown reasons, girls are necessary to fight for peace.
Their boss, lcy, wants to strengthen their ability, so he give them his precious collections---weapons for many years. Because these collections are really age-old, it is hard to recognize from one to another. So girls intend to sort them before they use. Each weapon has its name, origin and level of harmfulness ( level contains three ranks: wonderful, good, so-so).
In order to make it clear, girls want to sort like this:
firstly,sort according to the origin (sort by lexicographic order), if two or more have the same origin, they will be sorted together;
secondly, sort according ranks, wonderful is the best, good is next, the third is so-so;
thirdly, if two or more have same origin and rank, sort them according to the lexicographic order.


 

Input
Input contains multiply cases. Each case contains several lines. First line is an integer N(0<N<=500), representing the number of weapons. Then N lines follows. Each line represent a kind of weapon, and contains a set of strings representing name, origin and level of harmfulness. 
Each string will not exceed 20 characters.
Sure that same origin will not exist the same weapon.
 

Output
Please output your list after sorting (format according to sample, pay attention to the spaces,ten spaces need ^ ^).
 

Sample Input
  
  
5 knife qizhou so-so gun qizhou wonderful knife zhengzhou good stick zhengzhou good rope shengzhou so-so
 

Sample Output
  
  
Case 1 qizhou: gun wonderful knife so-so shengzhou: rope so-so zhengzhou: knife good stick good
 
代码如下:
#include<bits/stdc++.h>
using namespace std;
struct pp
{
    string ori,na,le;
    int l;
};
pp p[510];
bool cmp(const pp&a,const pp&b)
{
    if(a.ori!=b.ori)
        return a.ori<b.ori;
    else if(a.l!=b.l)
        return a.l<b.l;
    else
        return a.na<b.na;
}
set<string>origin;
int main()
{
    int n,t=1;
    while(cin>>n)
    {
        string a,b,c;
        for(int i=0;i<n;i++)
        {
            cin>>p[i].na>>p[i].ori>>p[i].le;
            origin.insert(p[i].ori);
            if(p[i].le[0]=='w')
                p[i].l=1;
            else if(p[i].le[0]=='g')
                p[i].l=2;
            else
                p[i].l=3;
        }
        int l=0;
        sort(p,p+n,cmp);
        cout<<"Case "<<t<<endl;
        for(set<string>::iterator it=origin.begin();it!=origin.end();it++)
        {
            cout<<*it<<":\n";
            for(;l<n&&*it==p[l].ori;l++)
                cout<<"          "<<p[l].na<<" "<<p[l].le<<endl;
        }
        t++;
        origin.clear();
    }
    return 0;
}


  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值