1085 -- 判断奇偶性

判断奇偶性

Time Limit:1000MS  Memory Limit:65536K
Total Submit:128 Accepted:58

Description

计算一个无符号整数x的二进制中1的个数是奇数还是偶数。

Input

多组测试数据。每组测试数据包括一个无符号整数n(0<n<2^32-1)

Output

若包含偶数个1,则输出even,否则输出odd。

Sample Input

8
7
6
15
4294967294
4294967295

Sample Output

odd
odd
even
even
odd
even

Source

    using System;
    using System.Collections.Generic;
    using System.Linq;
    using System.Text;
    namespace AK1085 {
        class Program {
            static void Main(string[] args) {
                string sb;
                while ((sb = Console.ReadLine()) != null) {
                    long n = long.Parse(sb);
                    long count = 0;
                    while (n > 0) {
                        count += n % 2;
                        n = n >> 1;
                    }
                    if (count % 2 == 0)
                        Console.WriteLine("even");
                    else
                        Console.WriteLine("odd");
                }
            }
        }
    }


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值