POJ 1141 Brackets Sequence

Description

Let us define a regular brackets sequence in the following way: 

1. Empty sequence is a regular sequence. 
2. If S is a regular sequence, then (S) and [S] are both regular sequences. 
3. If A and B are regular sequences, then AB is a regular sequence. 

For example, all of the following sequences of characters are regular brackets sequences: 

(), [], (()), ([]), ()[], ()[()] 

And all of the following character sequences are not: 

(, [, ), )(, ([)], ([(] 

Some sequence of characters '(', ')', '[', and ']' is given. You are to find the shortest possible regular brackets sequence, that contains the given character sequence as a subsequence. Here, a string a1 a2 ... an is called a subsequence of the string b1 b2 ... bm, if there exist such indices 1 = i1 < i2 < ... < in = m, that aj = bij for all 1 = j = n.

Input

The input file contains at most 100 brackets (characters '(', ')', '[' and ']') that are situated on a single line without any other characters among them.

Output

Write to the output file a single line that contains some regular brackets sequence that has the minimal possible length and contains the given sequence as a subsequence.

Sample Input

([(]

Sample Output

()[()]


动态规划求出最大匹配数,然后递归得到答案。

#include<stdio.h>
#include<algorithm>
#include<cstring>
#include<iostream>
#include<stack>
#include<map>
using namespace std;
const int maxn = 105;
map<char, char> M;
char s[maxn];
int f[maxn][maxn], p[maxn][maxn];

void dfs(int x, int y)
{
	if (x>y) return;
	if (x == y)
	{
		if (s[x] == '(' || s[x] == ')')printf("()");
		if (s[x] == '[' || s[x] == ']')printf("[]");
		return;
	}
	if (p[x][y]<0)
	{
		printf("%c", s[x]);
		dfs(x + 1, y - 1);
		printf("%c", s[y]);
		return;
	}
	if (p[x][y] >= x)
	{
		dfs(x, p[x][y]);
		dfs(p[x][y] + 1, y);
	}
}

int main()
{
	M['('] = ')'; M['['] = ']';
	M[')'] = '0'; M[')'] = '0';
	while (gets(s))
	{
		int n = strlen(s);
		memset(f, 0, sizeof(f));
		memset(p, 0, sizeof(p));
		for (int i = 1; i < n; i++)
		{
			for (int j = 0; j + i < n; j++)
			{
				p[j][j + i] = j;
				for (int k = 0; k < i; k++)
				{
					if (f[j][j + i]<f[j][j + k] + f[j + k + 1][j + i])
					{
						f[j][j + i] = f[j][j + k] + f[j + k + 1][j + i];
						p[j][j + i] = j + k;
					}
				}
				if (M[s[j]] == s[j + i])
				{
					if (f[j][j + i]<f[j + 1][j + i - 1] + 1)
					{
						f[j][j + i] = f[j + 1][j + i - 1] + 1;
						p[j][j + i] = -1;
					}
				}
			}
		}
		dfs(0, n - 1);
		printf("\n");
	}
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值