PAT (Advanced Level) Practise 1096 Consecutive Factors (20)

1096. Consecutive Factors (20)

时间限制
400 ms
内存限制
65536 kB
代码长度限制
16000 B
判题程序
Standard
作者
CHEN, Yue

Among all the factors of a positive integer N, there may exist several consecutive numbers. For example, 630 can be factored as 3*5*6*7, where 5, 6, and 7 are the three consecutive numbers. Now given any positive N, you are supposed to find the maximum number of consecutive factors, and list the smallest sequence of the consecutive factors.

Input Specification:

Each input file contains one test case, which gives the integer N (1<N<231).

Output Specification:

For each test case, print in the first line the maximum number of consecutive factors. Then in the second line, print the smallest sequence of the consecutive factors in the format "factor[1]*factor[2]*...*factor[k]", where the factors are listed in increasing order, and 1 is NOT included.

Sample Input:
630
Sample Output:
3

5*6*7

找连续的因子,因为范围不超过int,那其实最多能连续的也就12!来着的,所以暴力搞

#include<cstdio>
#include<vector>
#include<map>
#include<queue>
#include<string>
#include<iostream>
#include<cstring>
#include<algorithm>
using namespace std;
typedef long long LL;
const int INF = 0x7FFFFFFF;
const int maxn = 2e3 + 10;
LL n;

int main()
{
  scanf("%lld", &n);
  for (LL i = 11; i > 1; i--)
  {
    for (LL j = 2;; j++)
    {
      LL cnt = 1;
      for (LL k = j; k < j + i; k++) cnt *= k;
      if (cnt > n) break;
      if (n%cnt == 0)
      {
        printf("%d\n", i);
        for (LL k = j; k < j + i; k++) printf("%d%s", k, k + 1 == j + i ? "\n" : "*");
        return 0;
      }
    }
  }
  for (LL i = 2; i*i <= n; i++) if (n%i == 0) {
    printf("1\n%d\n", i); return 0;
  }
  printf("1\n%d\n", n);
  return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值