HDU2298:Toxophily(三分 + 二分)

Toxophily

Time Limit: 3000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 2068    Accepted Submission(s): 1147


Problem Description
The recreation center of WHU ACM Team has indoor billiards, Ping Pang, chess and bridge, toxophily, deluxe ballrooms KTV rooms, fishing, climbing, and so on.
We all like toxophily.

Bob is hooked on toxophily recently. Assume that Bob is at point (0,0) and he wants to shoot the fruits on a nearby tree. He can adjust the angle to fix the trajectory. Unfortunately, he always fails at that. Can you help him?

Now given the object's coordinates, please calculate the angle between the arrow and x-axis at Bob's point. Assume that g=9.8N/m. 
 

Input
The input consists of several test cases. The first line of input consists of an integer T, indicating the number of test cases. Each test case is on a separated line, and it consists three floating point numbers: x, y, v. x and y indicate the coordinate of the fruit. v is the arrow's exit speed.
Technical Specification

1. T ≤ 100.
2. 0 ≤ x, y, v ≤ 10000. 
 

Output
For each test case, output the smallest answer rounded to six fractional digits on a separated line.
Output "-1", if there's no possible answer.

Please use radian as unit. 
 

Sample Input
  
  
3 0.222018 23.901887 121.909183 39.096669 110.210922 20.270030 138.355025 2028.716904 25.079551
 

Sample Output
  
  
1.561582 -1 -1
 

Source
题意:二维面上给定目标坐标和初速度,求在坐标原点(0,0),发射出去能经过目标点的最小的角度。

思路:先用三分求出子弹经过横坐标x时所能达到的最大高度,再在此范围内二分出答案,目标在y轴上需要特判。设角度为θ,y = v*sinθ*t - 1/2*g*t*t,t = x / v*cosθ。

# include <iostream>
# include <cstdio>
# include <cmath>
# define pi acos(-1)
using namespace std;
double x, y, v;
double fun(double a)
{
    double t = x/(v*cos(a));
    return v*sin(a)*t - 4.9*t*t;
}
int main()
{
    int t;
    scanf("%d",&t);
    while(t--)
    {
        scanf("%lf%lf%lf",&x,&y,&v);
        double l=0, r=pi/2, mid, mmid;
        if(x == 0)
        {
            if(v*v/19.6 >= y)
                printf("%.6f\n",r);
            else
                puts("-1");
            continue;
        }
        for(int i=0; i<100; ++i)
        {
            mid = (l+r)/2;
            mmid = (mid+r)/2;
            if(fun(mid)>fun(mmid))
                r = mmid;
            else
                l = mid;
        }
        if(fun(l) < y)
        {
            puts("-1");
            continue;
        }
        l = 0;
        for(int i=0; i<100; ++i)
        {
            mid = (l+r)/2;
            if(fun(mid)>y)
                r = mid;
            else
                l = mid;
        }
        printf("%.6f\n",r);
    }
    return 0;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值