hdu 1075 What Are You Talking About Trie树

What Are You Talking About

Time Limit: 10000/5000 MS (Java/Others)    Memory Limit: 102400/204800 K (Java/Others)
Total Submission(s): 10372    Accepted Submission(s): 3306


Problem Description
Ignatius is so lucky that he met a Martian yesterday. But he didn't know the language the Martians use. The Martian gives him a history book of Mars and a dictionary when it leaves. Now Ignatius want to translate the history book into English. Can you help him?
 

Input
The problem has only one test case, the test case consists of two parts, the dictionary part and the book part. The dictionary part starts with a single line contains a string "START", this string should be ignored, then some lines follow, each line contains two strings, the first one is a word in English, the second one is the corresponding word in Martian's language. A line with a single string "END" indicates the end of the directory part, and this string should be ignored. The book part starts with a single line contains a string "START", this string should be ignored, then an article written in Martian's language. You should translate the article into English with the dictionary. If you find the word in the dictionary you should translate it and write the new word into your translation, if you can't find the word in the dictionary you do not have to translate it, and just copy the old word to your translation. Space(' '), tab('\t'), enter('\n') and all the punctuation should not be translated. A line with a single string "END" indicates the end of the book part, and that's also the end of the input. All the words are in the lowercase, and each word will contain at most 10 characters, and each line will contain at most 3000 characters.
 

Output
In this problem, you have to output the translation of the history book.
 

Sample Input
  
  
START from fiwo hello difh mars riwosf earth fnnvk like fiiwj END START difh, i'm fiwo riwosf. i fiiwj fnnvk! END
 

Sample Output
  
  
hello, i'm from mars. i like earth!
Hint
Huge input, scanf is recommended.
 

Author
Ignatius.L


火星文翻译
直接上模板




#include <iostream>
#include <cstdio>
#include <cstdlib>
#include <cstring>
using namespace std;

const int N=26;
typedef long long LL;

char s1[16],s2[16];
char a[3030];

struct Trie
{
    Trie *next[N];//next是表示每层有多少种类的数,如果只是小写字母,则26即可,若改为大小写字母,则是52,若再加上数字,则是62了,这里根据题意来确定。
    int v;//v可以表示一个字典树到此有多少相同前缀的数目,这里根据需要应当学会自由变化。
    char s[16];
}*root;


void createTrie(char *str2,char *str)
{
    int i,j,id;
    int len=strlen(str);
    Trie *p=root,*q;
    for(i=0; i<len; i++)
    {
        id=str[i]-'a';//这个地方依据题意来定
        if(p->next[id]==NULL)
        {
            q=(Trie *)malloc(sizeof(Trie));
            q->v=1;//如果没有的话,初始为1
            for(j=0; j<N; j++)
                q->next[j]=NULL;
            p->next[id]=q;
            p=p->next[id];
        }
        else
        {
            p->next[id]->v++;
            p=p->next[id];
        }
    }
    p->v=-1;//末尾节点,
    strcpy(p->s,str2);
}

bool findTrie(char *str)
{
    int i,id;
    int len=strlen(str);
    Trie *p=root;
    for(i=0; i<len; i++)
    {
        id=str[i]-'a';
        p=p->next[id];
        if(p==NULL)     //若为空集,表示不存以此为前缀的串
            return false;
    }
    if(p->v==-1)
    {
        printf("%s",p->s);
        return true;
    }
    return false;      //此串是字符集中某串的前缀
}

void dealTrie(Trie *T)
{
    //若果有多组数据-多棵树,那么要释放内纯
    int i;
    if(T==NULL)
        return ;
    for(i=0; i<N; i++)
        if(T->next[i]!=NULL)
            dealTrie(T->next[i]);
    free(T);//释放
}

int main()
{
    int i;
    root=(Trie *)malloc(sizeof(Trie));
    for(int i=0; i<N; i++)
        root->next[i] = NULL;
    scanf("%s",s1);
    while(scanf("%s",s1)&&strcmp(s1,"END")!=0)
    {
        scanf("%s",s2);
        createTrie(s1,s2);
    }
    scanf("%s",s1);
    getchar();
    while(gets(a)&&strcmp(a,"END")!=0)
    {
        int len=strlen(a);
        for(i=0; i<len; i++)
        {
            while(!isalpha(a[i]))
            {
                if(i>=len)
                    break;
                printf("%c",a[i]);
                i++;
            }
            int k=0;
            while(isalpha(a[i]))
            {
                s1[k]=a[i];
                k++;
                i++;
            }
            i--;
            s1[k]='\0';
            if(!findTrie(s1))
            {
                printf("%s",s1);
            }
        }
        printf("\n");
    }
    return 0;
}


 
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值