在 Ubuntu 20.04 LTS 上安装 VCS 后,需要做的一些配置

EDA Tools 专栏收录该内容
4 篇文章 0 订阅

前言

网上已经有不少在 Ubuntu 18.04 LTS 安装 VCS 的教程,但是网上的教程都是使用 alias 命令来配置 VCS 参数,这是不可行的,实际上如果有后续参数,alias 并不会传递参数。因此,我使用一个脚本来调用 vcs. 此外,Ubuntu 20.04 LTS 已经不再支持 gcc-4.8-multilib, g++-4.8-nultilib 两个软件包,网上不少教程都是教人手动编译,反正我是没有成功过。我在 Google 上检索了一下,发现对于 Ubuntu,只需要添加旧的软件源,就可以安装旧版本的软件。


1 安装 gcc-4.8, g++-4.8

1.1 添加旧的软件源到 source.list

deb https://mirrors.tuna.tsinghua.edu.cn/ubuntu/ bionic main restricted universe multiverse

这是直接套用的清华大学镜像站Ubuntu 镜像使用帮助提供的模板。

1.2 安装软件包

  • gcc-4.8-multilib
  • g+±4.8-nultilib

2 配置 VCS 的启动参数

2.1 编写启动 VCS 的脚本

文件名: vcs

文件内容:

#!/bin/bash
$VCS_HOME/bin/vcs -full64 -cpp g++-4.8 -cc gcc-4.8 -LDFLAGS -Wl,--no-as-needed $*

2.2 添加到 PATH

export PATH=/path/to/the/script:$PATH

这样保证此脚本仅仅覆盖原来的 vcs 命令。

  • 0
    点赞
  • 4
    评论
  • 3
    收藏
  • 打赏
    打赏
  • 扫一扫,分享海报

评论 4 您还未登录,请先 登录 后发表或查看评论
©️2022 CSDN 皮肤主题:书香水墨 设计师:CSDN官方博客 返回首页

打赏作者

k1435

你的鼓励将是我创作的最大动力

¥2 ¥4 ¥6 ¥10 ¥20
输入1-500的整数
余额支付 (余额:-- )
扫码支付
扫码支付:¥2
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、C币套餐、付费专栏及课程。

余额充值