1056. Mice and Rice (25)

Mice and Rice is the name of a programming contest in which each programmer must write a piece of code to control the movements of a mouse in a given map. The goal of each mouse is to eat as much rice as possible in order to become a FatMouse.

First the playing order is randomly decided for NP programmers. Then every NG programmers are grouped in a match. The fattest mouse in a group wins and enters the next turn. All the losers in this turn are ranked the same. Every NG winners are then grouped in the next match until a final winner is determined.

For the sake of simplicity, assume that the weight of each mouse is fixed once the programmer submits his/her code. Given the weights of all the mice and the initial playing order, you are supposed to output the ranks for the programmers.

Input Specification:

Each input file contains one test case. For each case, the first line contains 2 positive integers: NP and NG (<= 1000), the number of programmers and the maximum number of mice in a group, respectively. If there are less than NG mice at the end of the player's list, then all the mice left will be put into the last group. The second line contains NP distinct non-negative numbers Wi (i=0,...NP-1) where each Wi is the weight of the i-th mouse respectively. The third line gives the initial playing order which is a permutation of 0,...NP-1 (assume that the programmers are numbered from 0 to NP-1). All the numbers in a line are separated by a space.

Output Specification:

For each test case, print the final ranks in a line. The i-th number is the rank of the i-th programmer, and all the numbers must be separated by a space, with no extra space at the end of the line.

Sample Input:
11 3
25 18 0 46 37 3 19 22 57 56 10
6 0 8 7 10 5 9 1 4 2 3
Sample Output:
5 5 5 2 5 5 5 3 1 3 5

若干人随机分组进行比赛(可视为晋级赛),求每个人的排名。模拟这个晋级赛的过程。在求排名的函数中,对给出的排列,按每组m人(最后一组小于等于m人)分成若干组,对每一组组内进行比较,选出值最高的进入下一轮,用一个vector数组储存该人的序号。在对这一轮的全部人循环的同时,更新每个人的排名为当前的排名,而当前的排名就是进入下一轮的人的总数加一。然后以进入下一轮的人的序号数组为参数,递归调用求排名的函数。这样到最后就能得到正确的排名。


代码:

#include <iostream>
#include <cstring>
#include <vector>
#include <cstdlib>
#include <cstdio>
using namespace std;

vector<int>weight;
vector<int>ranks;

void func(vector<int>order,int m)
{
	int n=order.size();
	if(n==1) 
	{
		ranks[order[0]]=1;
		return;
	}
	vector<int>next;
	int cur_rank=(n/m)+((n%m)==0?0:1)+1;
	for(int i=0;i<n;)
	{
		int Max=-1,index,j;
		for(j=i;j<n&&j<i+m;j++)
		{
			if(Max<weight[order[j]])
			{
				Max=weight[order[j]];
				index=order[j];
			}
			ranks[order[j]]=cur_rank;
		}
		next.push_back(index);
		i=j;
	}
	func(next,m);
}

int main()
{
	int n,m;
	cin>>n>>m;
	weight.resize(n);
	for(int i=0;i<n;i++)
	{
		cin>>weight[i];
	}
	vector<int>order(n);
	for(int i=0;i<n;i++)
	{
		cin>>order[i];
	}
	ranks.resize(n);
	func(order,m);
	cout<<ranks[0];
	for(int i=1;i<n;i++) cout<<" "<<ranks[i];
}




  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值