1066. Root of AVL Tree (25)

An AVL tree is a self-balancing binary search tree. In an AVL tree, the heights of the two child subtrees of any node differ by at most one; if at any time they differ by more than one, rebalancing is done to restore this property. Figures 1-4 illustrate the rotation rules.

    
    

Now given a sequence of insertions, you are supposed to tell the root of the resulting AVL tree.

Input Specification:

Each input file contains one test case. For each case, the first line contains a positive integer N (<=20) which is the total number of keys to be inserted. Then N distinct integer keys are given in the next line. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print ythe root of the resulting AVL tree in one line.

Sample Input 1:
5
88 70 61 96 120
Sample Output 1:
70
Sample Input 2:
7
88 70 61 96 120 90 65
Sample Output 2:
88

考察构建平衡二叉树的一些操作。


代码:

#include <iostream>
#include <cstring>
#include <cstdlib>
#include <cstdio>
#include <vector>
using namespace std;

struct node
{
	int val;
	node *left;
	node *right;
	int height;
	node(int v,int h):val(v),left(NULL),right(NULL),height(h){}
};

int get_height(node *n)
{
	if(n==NULL) return 0;
	else return n->height;
}

node* l_rotate(node *x)
{
	node *y=x->left;
	x->left=y->right;
	y->right=x;
	x->height=max(get_height(x->left),get_height(x->right))+1;
	y->height=max(get_height(y->left),get_height(y->right))+1;
	return y;
}

node* r_rotate(node *x)
{
	node *y=x->right;
	x->right=y->left;
	y->left=x;
	x->height=max(get_height(x->left),get_height(x->right))+1;
	y->height=max(get_height(y->left),get_height(y->right))+1;
	return y;
}

node* lr_rotate(node *x)
{
	x->left=r_rotate(x->left);
	return l_rotate(x);
}

node* rl_rotate(node *x)
{
	x->right=l_rotate(x->right);
	return r_rotate(x);
}

node* Insert(int x,node *root)
{
	if(root==NULL) 
	{
		root=new node(x,1);
	}
	else if(x<root->val)
	{
		root->left=Insert(x,root->left);
		if(get_height(root->left)-get_height(root->right)==2)
		{
			if(x<root->left->val)
				root=l_rotate(root);
			else
				root=lr_rotate(root);
		}
	}
	else if(x>root->val)
	{
		root->right=Insert(x,root->right);
		if(get_height(root->right)-get_height(root->left)==2)
		{
			if(x>root->right->val)
				root=r_rotate(root);
			else
				root=rl_rotate(root);
		}
	}
	root->height=max(get_height(root->left),get_height(root->right))+1;
	return root;
}

int main()
{
	int n;
	cin>>n;
	node *root=NULL;
	for(int i=0;i<n;i++)
	{
		int x;
		cin>>x;
		root=Insert(x,root);
	}
	cout<<root->val<<endl;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值